summaryrefslogtreecommitdiff
path: root/dev-games/openscenegraph-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/openscenegraph-qt
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/openscenegraph-qt')
-rw-r--r--dev-games/openscenegraph-qt/Manifest4
-rw-r--r--dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch53
-rw-r--r--dev-games/openscenegraph-qt/metadata.xml15
-rw-r--r--dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild45
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-qt/Manifest b/dev-games/openscenegraph-qt/Manifest
new file mode 100644
index 000000000000..dbb058c8639f
--- /dev/null
+++ b/dev-games/openscenegraph-qt/Manifest
@@ -0,0 +1,4 @@
+AUX openscenegraph-qt-3.5.5-cmake.patch 3190 SHA256 662ecd9f72b17749f3845665a65c0b814c581981bfb900b2c12939e9b5f5297e SHA512 b5350082a9755f73274103b1bc6d5b08954cd6b23e22d15e26e617bd55016ab3df29c0712af775e4e357213456fd8daa4d443f28b06979e76e32ce0df60393a1 WHIRLPOOL 6d885f84d789010d08547f8eea34fde4dcaf6575aae771d4a88e0072c6aebf03b5b7a6e2b61205fa760a0a2eccf5d6c2603f3199ef809db3cc34d981ff581639
+DIST osgQt-3.5.5.tar.gz 1003973 SHA256 3e20af0496615077c2182e676fdee2a141a4216bf2f8af151197161aa3b88d1f SHA512 50faee9a1539c1e29bb1c244fa32194b22cbe43f43980b7c270aa45cd225ac5e3fe9445d63b1efb767c8a2ce8e5ffa417783d1a446ed965b23a06100a241d498 WHIRLPOOL 341844ba09ac7b01615be6bf6ad3bcbc48bb1203b4083aa8a9077e6399e64c7f5057cbf8abef7e265d5d13679aa9000fd7affb0ea86e94e1c1b113f4d8180f8d
+EBUILD openscenegraph-qt-3.5.5.ebuild 935 SHA256 e0bc056cac9d86f91cbfeb66aacaca40c41fb6519820d112e184ab7a3fffaaa4 SHA512 78498f15d294ebe9706cc8d5146a6196345e05da6b1e6cd9f73ada81a55d95a8e4bed9090e643c56b7a346c0af1b08f2ebf45a6eaaf28ee7ff7ab3ea50ec14a4 WHIRLPOOL 774ccbdb09c26d0b9f79a305e7484cd6bc62cf87c472778fd23538e51a00e08684dae36bae328c72f8dbc7b157e5bae092956346b694f038276f94da2ee80868
+MISC metadata.xml 993 SHA256 1af372a4ad34c9b7491d980535622686fdad34f7ebdb1f61e94318830ec55618 SHA512 2e95379c212b8f0a0d5bb4ef3ee16d29dae6b9923fff0d07d01a4f2d08d276a536fa5354ea2e210a641f01d805d5ab543b908e67323040abca40aa3afcfe7aa3 WHIRLPOOL c330fb9561c33b8908cb4942f77cd50827e185ead127d4610df3d362a4e40c527ea97e97573f0ea507b3493ce7d91232213a6098d488229a754d0ca96585a4e8
diff --git a/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch
new file mode 100644
index 000000000000..e5cac15373d8
--- /dev/null
+++ b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch
@@ -0,0 +1,53 @@
+diff -ruN osgQt-3.5.5/CMakeLists.txt my/CMakeLists.txt
+--- osgQt-3.5.5/CMakeLists.txt 2016-09-20 07:11:32.000000000 +0200
++++ my/CMakeLists.txt 2017-05-18 04:11:06.929237731 +0200
+@@ -543,15 +543,7 @@
+ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG")
+ ENDIF()
+
+-IF(UNIX AND NOT WIN32 AND NOT APPLE)
+- IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
+- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
+- MARK_AS_ADVANCED(LIB_POSTFIX)
+- ENDIF()
+-ENDIF()
+-IF(NOT DEFINED LIB_POSTFIX)
+- SET(LIB_POSTFIX "")
+-ENDIF()
++SET(LIB_POSTFIX ${LIB_SUFFIX})
+
+ # Here we apparantly do some funky stuff with making the bin/ and lib/
+ # folders which is probably needed to work around a very old CMake bug?
+@@ -877,7 +869,7 @@
+ ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs/osg32-32.png COPYONLY
+ )
+ #INSTALL(FILES ${PROJECT_BINARY_DIR}/doc/${PROJECT_NAME}ReferenceDocs-${OPENSCENEGRAPH_VERSION}.chm DESTINATION doc OPTIONAL COMPONENT openscenegraph-doc)
+- INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs DESTINATION doc COMPONENT openscenegraph-doc)
++ INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs DESTINATION ${GENTOO_DOCDIR} COMPONENT openscenegraph-doc)
+
+ # now set up openthreads documentation generation
+ IF(BUILD_REF_DOCS_TAGFILE)
+@@ -893,7 +885,7 @@
+ ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs/osg32-32.png COPYONLY
+ )
+ #INSTALL(FILES ${PROJECT_BINARY_DIR}/doc/${PROJECT_NAME}ReferenceDocs-${OPENSCENEGRAPH_VERSION}.chm DESTINATION doc OPTIONAL COMPONENT openscenegraph-doc)
+- INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs DESTINATION doc COMPONENT openthreads-doc)
++ INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs DESTINATION ${GENTOO_DOCDIR} COMPONENT openthreads-doc)
+
+ # Process our other doxyfiles but don't create targets for these
+ CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/doc/Doxyfiles/all_Doxyfile
+diff -ruN osgQt-3.5.5/CMakeModules/OsgMacroUtils.cmake my/CMakeModules/OsgMacroUtils.cmake
+--- osgQt-3.5.5/CMakeModules/OsgMacroUtils.cmake 2016-09-20 07:11:32.000000000 +0200
++++ my/CMakeModules/OsgMacroUtils.cmake 2017-05-18 04:30:26.646257926 +0200
+@@ -462,9 +462,9 @@
+ IF(APPLE)
+ INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION share/OpenSceneGraph/bin BUNDLE DESTINATION share/OpenSceneGraph/bin )
+ ELSE(APPLE)
+- INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION share/OpenSceneGraph/bin COMPONENT openscenegraph-examples )
++ INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION bin COMPONENT openscenegraph-examples )
+ IF(MSVC AND NOT CMAKE_BUILD_TYPE STREQUAL "Release")
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${TARGET_TARGETNAME}${CMAKE_BUILD_POSTFIX}.pdb DESTINATION share/OpenSceneGraph/bin COMPONENT openscenegraph-examples)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${TARGET_TARGETNAME}${CMAKE_BUILD_POSTFIX}.pdb DESTINATION bin COMPONENT openscenegraph-examples)
+ ENDIF(MSVC AND NOT CMAKE_BUILD_TYPE STREQUAL "Release")
+ ENDIF(APPLE)
+
diff --git a/dev-games/openscenegraph-qt/metadata.xml b/dev-games/openscenegraph-qt/metadata.xml
new file mode 100644
index 000000000000..9658acfd106c
--- /dev/null
+++ b/dev-games/openscenegraph-qt/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+<longdescription lang="en">
+The OpenSceneGraph is an open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries. This package is a module for Qt support.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
new file mode 100644
index 000000000000..b0d18aaf7f45
--- /dev/null
+++ b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="osgQt"
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+DESCRIPTION="Qt support for OpenSceneGraph"
+HOMEPAGE="http://www.openscenegraph.org/"
+SRC_URI="https://github.com/openscenegraph/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3 LGPL-2.1"
+SLOT="0/145" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="debug examples"
+
+RDEPEND="
+ dev-games/openscenegraph:${SLOT}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwebkit:5
+ examples? ( dev-qt/qtwidgets:5 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.5-cmake.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDYNAMIC_OPENSCENEGRAPH=ON
+ -DDESIRED_QT_VERSION=5
+ -DBUILD_OSG_EXAMPLES=$(usex examples)
+ )
+
+ cmake-utils_src_configure
+}