summaryrefslogtreecommitdiff
path: root/dev-games/ogre/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-games/ogre/files
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-games/ogre/files')
-rw-r--r--dev-games/ogre/files/ogre-1.12.4-fix_sample_source_install.patch15
-rw-r--r--dev-games/ogre/files/ogre-1.12.8-fix_Simple_demo.patch11
-rw-r--r--dev-games/ogre/files/ogre-1.12.8-media_path.patch (renamed from dev-games/ogre/files/ogre-1.12.4-media_path.patch)0
-rw-r--r--dev-games/ogre/files/ogre-1.12.8-resource_path.patch (renamed from dev-games/ogre/files/ogre-1.12.4-resource_path.patch)0
-rw-r--r--dev-games/ogre/files/ogre-1.12.8-upgrade_imgui.patch28
-rw-r--r--dev-games/ogre/files/ogre-2.1-d1c1116.patch62
-rw-r--r--dev-games/ogre/files/ogre-2.1-fix_compilation_issues.patch67
-rw-r--r--dev-games/ogre/files/ogre-2.1-fix_opengl_search.patch12
-rw-r--r--dev-games/ogre/files/ogre-2.1-fix_warnings.patch15
9 files changed, 195 insertions, 15 deletions
diff --git a/dev-games/ogre/files/ogre-1.12.4-fix_sample_source_install.patch b/dev-games/ogre/files/ogre-1.12.4-fix_sample_source_install.patch
deleted file mode 100644
index 616a5e33680b..000000000000
--- a/dev-games/ogre/files/ogre-1.12.4-fix_sample_source_install.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-The SDK_CMakeLists.txt.in file does not exist at the moment (sed - 2018-04-25)
-
---- a/Samples/CMakeLists.txt 2018-04-25 07:30:38.211048775 +0200
-+++ b/Samples/CMakeLists.txt 2018-04-25 07:32:32.842049802 +0200
-@@ -97,10 +97,6 @@
- PATTERN "scripts" EXCLUDE
- )
- # install a new CMakeLists.txt file to allow building of samples
-- configure_file(${OGRE_TEMPLATES_DIR}/SDK_CMakeLists.txt.in ${CMAKE_CURRENT_BINARY_DIR}/../CMakeLists.txt @ONLY)
-- configure_file(${OGRE_TEMPLATES_DIR}/SDK_Samples_CMakeLists.txt.in ${CMAKE_CURRENT_BINARY_DIR}/CMakeLists.txt @ONLY)
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/../CMakeLists.txt DESTINATION ${OGRE_SAMPLES_DIR}/../)
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/CMakeLists.txt DESTINATION ${OGRE_SAMPLES_DIR})
- endif ()
-
- # Install sample headers, some people rely on these
diff --git a/dev-games/ogre/files/ogre-1.12.8-fix_Simple_demo.patch b/dev-games/ogre/files/ogre-1.12.8-fix_Simple_demo.patch
new file mode 100644
index 000000000000..49ed0190e0a1
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.12.8-fix_Simple_demo.patch
@@ -0,0 +1,11 @@
+--- a/Samples/Simple/include/SSAO.h 2020-04-26 13:54:31.321908377 +0200
++++ b/Samples/Simple/include/SSAO.h 2020-04-26 13:54:47.497909935 +0200
+@@ -65,7 +65,7 @@
+ SSAOGBufferSchemeHandler()
+ {
+ mGBufRefMat = Ogre::MaterialManager::getSingleton().getByName("SSAO/GBuffer");
+- RTShader::ShaderGenerator::getSingleton().validateMaterial("GBuffer", "SSAO/GBuffer");
++ RTShader::ShaderGenerator::getSingleton().validateMaterial("GBuffer", "SSAO/GBuffer", "OgreAutodetect");
+ mGBufRefMat->load();
+ }
+
diff --git a/dev-games/ogre/files/ogre-1.12.4-media_path.patch b/dev-games/ogre/files/ogre-1.12.8-media_path.patch
index 3030cc5b9fad..3030cc5b9fad 100644
--- a/dev-games/ogre/files/ogre-1.12.4-media_path.patch
+++ b/dev-games/ogre/files/ogre-1.12.8-media_path.patch
diff --git a/dev-games/ogre/files/ogre-1.12.4-resource_path.patch b/dev-games/ogre/files/ogre-1.12.8-resource_path.patch
index cf35e2f99e8e..cf35e2f99e8e 100644
--- a/dev-games/ogre/files/ogre-1.12.4-resource_path.patch
+++ b/dev-games/ogre/files/ogre-1.12.8-resource_path.patch
diff --git a/dev-games/ogre/files/ogre-1.12.8-upgrade_imgui.patch b/dev-games/ogre/files/ogre-1.12.8-upgrade_imgui.patch
new file mode 100644
index 000000000000..4c7803a0a2f2
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.12.8-upgrade_imgui.patch
@@ -0,0 +1,28 @@
+--- a/Components/Overlay/CMakeLists.txt 2020-08-16 17:45:59.605165822 +0200
++++ b/Components/Overlay/CMakeLists.txt 2020-08-16 17:48:45.796175402 +0200
+@@ -19,14 +19,14 @@
+ file(GLOB SOURCE_FILES "${CMAKE_CURRENT_SOURCE_DIR}/src/*.cpp")
+
+ if(OGRE_BUILD_COMPONENT_OVERLAY_IMGUI)
+- set(IMGUI_DIR "${PROJECT_BINARY_DIR}/imgui-1.73" CACHE PATH "")
++ set(IMGUI_DIR "${PROJECT_SOURCE_DIR}/imgui-1.76" CACHE PATH "")
+ if(NOT EXISTS ${IMGUI_DIR})
+ message(STATUS "Dowloading imgui")
+ file(DOWNLOAD
+- https://github.com/ocornut/imgui/archive/v1.73.tar.gz
+- ${PROJECT_BINARY_DIR}/imgui.tar.gz)
++ https://github.com/ocornut/imgui/archive/v1.76.tar.gz
++ ${PROJECT_SOURCE_DIR}/imgui.tar.gz)
+ execute_process(COMMAND ${CMAKE_COMMAND}
+- -E tar xf imgui.tar.gz WORKING_DIRECTORY ${PROJECT_BINARY_DIR})
++ -E tar xf imgui.tar.gz WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
+ endif()
+ list(APPEND SOURCE_FILES
+ ${IMGUI_DIR}/imgui.cpp
+@@ -84,4 +84,4 @@
+ )
+ install(FILES "${PROJECT_SOURCE_DIR}/Media/packs/profiler.zip"
+ DESTINATION "${OGRE_MEDIA_PATH}/packs/"
+-)
+\ Kein Zeilenumbruch am Dateiende.
++)
diff --git a/dev-games/ogre/files/ogre-2.1-d1c1116.patch b/dev-games/ogre/files/ogre-2.1-d1c1116.patch
new file mode 100644
index 000000000000..6fbf5ecda4d0
--- /dev/null
+++ b/dev-games/ogre/files/ogre-2.1-d1c1116.patch
@@ -0,0 +1,62 @@
+From d1c1116924ca537c1f061ed5422dd9a5207d989a Mon Sep 17 00:00:00 2001
+From: "Matias N. Goldberg" <dark_sylinc@yahoo.com.ar>
+Date: Mon, 24 Feb 2020 17:23:25 -0300
+Subject: [PATCH] Bugfix: Bone::_getDerivedTransform using uninitialized values
+ causing asserts to trigger Also prefer using Mathlib::LAST_AFFINE_COLUMN in
+ ArrayMatrixAf4x3::store
+
+---
+ .../include/Math/Array/NEON/Single/OgreArrayMatrixAf4x3.h | 6 +-----
+ .../include/Math/Array/SSE2/Single/OgreArrayMatrixAf4x3.h | 6 +-----
+ OgreMain/src/Animation/OgreBone.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 12 deletions(-)
+
+diff --git a/OgreMain/include/Math/Array/NEON/Single/OgreArrayMatrixAf4x3.h b/OgreMain/include/Math/Array/NEON/Single/OgreArrayMatrixAf4x3.h
+index 137b7cb5b2..2e2468149d 100644
+--- a/OgreMain/include/Math/Array/NEON/Single/OgreArrayMatrixAf4x3.h
++++ b/OgreMain/include/Math/Array/NEON/Single/OgreArrayMatrixAf4x3.h
+@@ -217,11 +217,7 @@ namespace Ogre
+ vst1q_f32( dstPtr, mChunkBase[0] );
+ vst1q_f32( dstPtr + 4, mChunkBase[1] );
+ vst1q_f32( dstPtr + 8, mChunkBase[2] );
+- dstPtr += 12;
+- *dstPtr++ = 0;
+- *dstPtr++ = 0;
+- *dstPtr++ = 0;
+- *dstPtr++ = 1;
++ vst1q_f32( dstPtr + 12, MathlibNEON::LAST_AFFINE_COLUMN );
+ }
+
+ /// Assumes dst is aligned
+diff --git a/OgreMain/include/Math/Array/SSE2/Single/OgreArrayMatrixAf4x3.h b/OgreMain/include/Math/Array/SSE2/Single/OgreArrayMatrixAf4x3.h
+index 01b75b2730..a96d9a11e0 100644
+--- a/OgreMain/include/Math/Array/SSE2/Single/OgreArrayMatrixAf4x3.h
++++ b/OgreMain/include/Math/Array/SSE2/Single/OgreArrayMatrixAf4x3.h
+@@ -217,11 +217,7 @@ namespace Ogre
+ _mm_store_ps( dstPtr, mChunkBase[0] );
+ _mm_store_ps( dstPtr + 4, mChunkBase[1] );
+ _mm_store_ps( dstPtr + 8, mChunkBase[2] );
+- dstPtr += 12;
+- *dstPtr++ = 0;
+- *dstPtr++ = 0;
+- *dstPtr++ = 0;
+- *dstPtr++ = 1;
++ _mm_store_ps( dstPtr + 12, MathlibSSE2::LAST_AFFINE_COLUMN );
+ }
+
+ /// Assumes dst is aligned
+diff --git a/OgreMain/src/Animation/OgreBone.cpp b/OgreMain/src/Animation/OgreBone.cpp
+index 588c6cb442..8735ed2a2f 100644
+--- a/OgreMain/src/Animation/OgreBone.cpp
++++ b/OgreMain/src/Animation/OgreBone.cpp
+@@ -257,8 +257,8 @@ namespace Ogre {
+ OGRE_ALIGNED_DECL( Matrix4, localSpaceBone, OGRE_SIMD_ALIGNMENT );
+ OGRE_ALIGNED_DECL( Matrix4, parentNodeTransform, OGRE_SIMD_ALIGNMENT );
+
+- mTransform.mDerivedTransform[mTransform.mIndex].store4x3( &localSpaceBone );
+- mTransform.mParentNodeTransform[mTransform.mIndex]->store4x3( &parentNodeTransform );
++ mTransform.mDerivedTransform[mTransform.mIndex].store( &localSpaceBone );
++ mTransform.mParentNodeTransform[mTransform.mIndex]->store( &parentNodeTransform );
+
+ parentNodeTransform.concatenateAffine( localSpaceBone );
+
diff --git a/dev-games/ogre/files/ogre-2.1-fix_compilation_issues.patch b/dev-games/ogre/files/ogre-2.1-fix_compilation_issues.patch
new file mode 100644
index 000000000000..4f2248dd1a36
--- /dev/null
+++ b/dev-games/ogre/files/ogre-2.1-fix_compilation_issues.patch
@@ -0,0 +1,67 @@
+--- a/Components/Paging/src/OgreGrid3DPageStrategy.cpp 2020-04-28 09:31:06.301940556 +0200
++++ b/Components/Paging/src/OgreGrid3DPageStrategy.cpp 2020-04-28 09:40:51.777904025 +0200
+@@ -367,9 +367,9 @@
+ {
+ mat = MaterialManager::getSingleton().create(matName, ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME);
+ Pass* pass = mat->getTechnique(0)->getPass(0);
+- pass->setLightingEnabled(false);
++ //pass->setLightingEnabled(false);
+ pass->setVertexColourTracking(TVC_AMBIENT);
+- pass->setDepthWriteEnabled(false);
++ //pass->setDepthWriteEnabled(false);
+ mat->load();
+ }
+
+@@ -383,7 +383,7 @@
+ else
+ {
+ mo = p->getParentSection()->getSceneManager()->createManualObject();
+- mo->begin(matName, RenderOperation::OT_LINE_STRIP);
++ mo->begin(matName, OperationType::OT_LINE_STRIP);
+ }
+
+ ColourValue vcol = ColourValue::Green;
+--- a/Components/Paging/src/OgreGrid2DPageStrategy.cpp 2020-04-28 09:43:23.119894582 +0200
++++ b/Components/Paging/src/OgreGrid2DPageStrategy.cpp 2020-04-28 09:44:00.844892228 +0200
+@@ -405,9 +405,9 @@
+ {
+ mat = MaterialManager::getSingleton().create(matName, ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME);
+ Pass* pass = mat->getTechnique(0)->getPass(0);
+- pass->setLightingEnabled(false);
++ //pass->setLightingEnabled(false);
+ pass->setVertexColourTracking(TVC_AMBIENT);
+- pass->setDepthWriteEnabled(false);
++ //pass->setDepthWriteEnabled(false);
+ mat->load();
+ }
+
+@@ -416,7 +416,7 @@
+ if (sn->numAttachedObjects() == 0)
+ {
+ mo = p->getParentSection()->getSceneManager()->createManualObject();
+- mo->begin(matName, RenderOperation::OT_LINE_STRIP);
++ mo->begin(matName, OperationType::OT_LINE_STRIP);
+ }
+ else
+ {
+--- a/OgreMain/src/OgrePVRTCCodec.cpp 2020-04-27 20:00:44.816974345 +0200
++++ b/OgreMain/src/OgrePVRTCCodec.cpp 2020-04-27 20:03:49.186962841 +0200
+@@ -33,6 +33,7 @@
+ #include "OgreException.h"
+ #include "OgreLogManager.h"
+ #include "OgreBitwise.h"
++#include "OgreDataStream.h"
+
+ #define FOURCC(c0, c1, c2, c3) (c0 | (c1 << 8) | (c2 << 16) | (c3 << 24))
+ #define PVR_TEXTURE_FLAG_TYPE_MASK 0xff
+--- a/OgreMain/src/OgrePlatformInformation.cpp 2020-08-23 17:39:09.971041355 +0200
++++ b/OgreMain/src/OgrePlatformInformation.cpp 2020-08-23 17:40:11.594044907 +0200
+@@ -42,7 +42,7 @@
+ #if OGRE_PLATFORM != OGRE_PLATFORM_WIN32
+ #if OGRE_PLATFORM == OGRE_PLATFORM_ANDROID
+ #include <linux/sysctl.h>
+- #else
++ #elif OGRE_PLATFORM == OGRE_PLATFORM_APPLE || OGRE_PLATFORM == OGRE_PLATFORM_APPLE_IOS
+ #include <sys/sysctl.h>
+ #endif
+ #endif
diff --git a/dev-games/ogre/files/ogre-2.1-fix_opengl_search.patch b/dev-games/ogre/files/ogre-2.1-fix_opengl_search.patch
new file mode 100644
index 000000000000..e5a09804407b
--- /dev/null
+++ b/dev-games/ogre/files/ogre-2.1-fix_opengl_search.patch
@@ -0,0 +1,12 @@
+--- a/CMake/Dependencies.cmake 2020-04-27 15:59:25.005877828 +0200
++++ b/CMake/Dependencies.cmake 2020-04-27 15:59:42.572876732 +0200
+@@ -111,6 +111,9 @@
+ #######################################################################
+
+ # Find OpenGL
++if(POLICY CMP0072)
++ cmake_policy(SET CMP0072 NEW)
++endif()
+ if(NOT ANDROID AND NOT EMSCRIPTEN)
+ find_package(OpenGL)
+ macro_log_feature(OPENGL_FOUND "OpenGL" "Support for the OpenGL render system" "http://www.opengl.org/" FALSE "" "")
diff --git a/dev-games/ogre/files/ogre-2.1-fix_warnings.patch b/dev-games/ogre/files/ogre-2.1-fix_warnings.patch
new file mode 100644
index 000000000000..a76687998889
--- /dev/null
+++ b/dev-games/ogre/files/ogre-2.1-fix_warnings.patch
@@ -0,0 +1,15 @@
+--- a/Samples/2.0/Tutorials/Tutorial_Terrain/src/Terra/TerrainCell.cpp 2020-04-28 18:10:40.416995414 +0200
++++ b/Samples/2.0/Tutorials/Tutorial_Terrain/src/Terra/TerrainCell.cpp 2020-04-28 18:30:46.074920186 +0200
+@@ -133,7 +133,11 @@
+ gpuPtr[0] = m_verticesPerLine;
+ gpuPtr[1] = m_lodLevel;
+ gpuPtr[2] = vao->getPrimitiveCount() / m_verticesPerLine - 2u;
+- gpuPtr[3] = *reinterpret_cast<uint32*>( &m_parentTerra->m_skirtSize );
++ /* Triggers: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
++ * gpuPtr[3] = *reinterpret_cast<uint32*>( &m_parentTerra->m_skirtSize );
++ * See: http://zaynar.co.uk/docs/float-aliasing.html
++ */
++ memcpy(&gpuPtr[3], &m_parentTerra->m_skirtSize, sizeof(gpuPtr[3]));
+
+ //ivec4 xzTexPosBounds
+ ((int32*RESTRICT_ALIAS)gpuPtr)[4] = m_gridX;