summaryrefslogtreecommitdiff
path: root/dev-games/libnw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-games/libnw
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-games/libnw')
-rw-r--r--dev-games/libnw/Manifest2
-rw-r--r--dev-games/libnw/libnw-1.30.02.ebuild35
2 files changed, 25 insertions, 12 deletions
diff --git a/dev-games/libnw/Manifest b/dev-games/libnw/Manifest
index 7feda622ba2d..45fed7db8036 100644
--- a/dev-games/libnw/Manifest
+++ b/dev-games/libnw/Manifest
@@ -1,3 +1,3 @@
DIST libnw-1.30.02.tar.gz 317336 BLAKE2B 0e7298b409bfa6034a28f5f27e3c4103367fd8adca58bb7510d12aa641a3bea162e82e17343adbd3a1ded94ec9834231def9e4d0ad264512923ffcc0b63625f1 SHA512 5175fe6737dc1a3ddd5e53354435ff0db56ad560f24e330f348190b2ed9e6d2418dc20497dcb64f316572c4c75b298fe12794fde73516347d70e737700f67939
-EBUILD libnw-1.30.02.ebuild 648 BLAKE2B af2d39bc7da110cc96b3ce1464be80cd4ae5fd5ad8527cfab52e2d5f5891f17f193e5fc65d63fc56765427556482e19016059558cbc4d531aa8e3e4937955ed2 SHA512 ed38b757ccb6a879f746d926a6ad0028a77dd8250d09bfcac425a4ce2ab41978104714c1d0756ecd7d54b88fbae1d559b1a32e2c29e6161b80ff10b386c65517
+EBUILD libnw-1.30.02.ebuild 869 BLAKE2B 59cf65af8b2d0f25b3f8a1a0ac79e3653eafe903f1653ca9dfaf12e91e7fd72d18e6cfdd66aee4afae4b3b5ee4e6220f013d9fde589e74d8ef9e25dbf9d4b27d SHA512 795b6113d971e460cc3082244570760d32a51fcc116aaffa880f609d9973eb38318752773ed432bb5d838f2f4298eb651e6641b6534c4c024dd3093f76f0711b
MISC metadata.xml 1005 BLAKE2B c05bcb17a2d3154e59d8df433ae4d2d4a68243d8031b1393890e528dec94886434a45bf967e9f3c5e11cdd0487d200b517c39bc95ddf8047054ad953c122d974 SHA512 126197d5c5117e3a491dfe5c18103a3544ffdef8c6bd8ac300fecb716e4324f2d0ea07183cd648ac552c8a2b2c37a3cb9a33a5a2898596678da88416bd697ab7
diff --git a/dev-games/libnw/libnw-1.30.02.ebuild b/dev-games/libnw/libnw-1.30.02.ebuild
index 7cd617c7c93e..2d64032d35d8 100644
--- a/dev-games/libnw/libnw-1.30.02.ebuild
+++ b/dev-games/libnw/libnw-1.30.02.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Tools and libraries for NWN file manipulation"
@@ -11,21 +12,33 @@ SRC_URI="mirror://sourceforge/openknights/${P}.tar.gz"
LICENSE="openknights"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND="sys-devel/bison
- sys-devel/flex"
RDEPEND="!sci-biology/newick-utils"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog NEWS README README.tech TODO )
src_prepare() {
- sed -i \
- -e '/^CC =/d' \
- -e '/^CXX =/d' \
- $(find . -name Makefile.in) || die
+ default
+
+ local f
+ while IFS="" read -d $'\0' -r f; do
+ einfo "Removing hardcoded CC/CXX from ${f}"
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CXX =/d' \
+ "${f}" || die
+ done < <(find "${S}" -name Makefile.in -type f -print0)
+}
+
+src_configure() {
tc-export CC CXX
+ econf --disable-static
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README README.tech TODO" \
- default
+ default
+ find "${ED}" -name '*.la' -delete || die
}