summaryrefslogtreecommitdiff
path: root/dev-games/libnw/libnw-1.30.02.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/libnw/libnw-1.30.02.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/libnw/libnw-1.30.02.ebuild')
-rw-r--r--dev-games/libnw/libnw-1.30.02.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-games/libnw/libnw-1.30.02.ebuild b/dev-games/libnw/libnw-1.30.02.ebuild
new file mode 100644
index 000000000000..7cd617c7c93e
--- /dev/null
+++ b/dev-games/libnw/libnw-1.30.02.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Tools and libraries for NWN file manipulation"
+HOMEPAGE="http://openknights.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openknights/${P}.tar.gz"
+
+LICENSE="openknights"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND="!sci-biology/newick-utils"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CXX =/d' \
+ $(find . -name Makefile.in) || die
+ tc-export CC CXX
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README README.tech TODO" \
+ default
+}