summaryrefslogtreecommitdiff
path: root/dev-games/libmt_client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/libmt_client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/libmt_client')
-rw-r--r--dev-games/libmt_client/Manifest4
-rw-r--r--dev-games/libmt_client/files/libmt_client-0.1.98-format.patch50
-rw-r--r--dev-games/libmt_client/libmt_client-0.1.98.ebuild24
-rw-r--r--dev-games/libmt_client/metadata.xml21
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-games/libmt_client/Manifest b/dev-games/libmt_client/Manifest
new file mode 100644
index 000000000000..e0eec73e9673
--- /dev/null
+++ b/dev-games/libmt_client/Manifest
@@ -0,0 +1,4 @@
+AUX libmt_client-0.1.98-format.patch 2325 BLAKE2B 01827a1a89ae4ad36c6c655b1bfa6a0391cb0e556777873fcf01840ab13ef133dde7e0330b9ef266d3a6b0eb5c5a85fe731bff03ec8be6e7ffbb499edd8b9dd1 SHA512 c4ee6b5a5ef2a62f8022fe6672c2cf9769e9f120fad3abcbbd86c1ff12bc66c5d36ba285b8576eb410cb337c9bbb3e11c9941761a024f0d445b143a1d3de4d65
+DIST libmt_client-0.1.98.tar.bz2 146319 BLAKE2B 0edd2690f8139f62a9f31a19bd869e98f213b613a76ca735b5b95fdc7fb01f8d3e4739828f0d5c3ab0f0f4597875c1334304b1888e3dd237d0e2f6fb19c553ba SHA512 1eb53bd36a171dbc3138942ec8314aaf8a71ca207060ea6d7499d18c2680fe8ebc822d8ec9843675a7c329039d2c985783f239b74b13c004e47a38250a8c4411
+EBUILD libmt_client-0.1.98.ebuild 527 BLAKE2B cdfc8e71ad30f2a174e4d6741fc25532b35a09c0bf58f8ef3b14bf01ce32b0e76c9d98fea1b04403fdf4422f90d1cd516b237f24442b7ffd69d32fe2b6e05ae2 SHA512 f3739072f22a10bd7713ba4a3263c571ecfdc488b6ba0e152fd0be417ebeca8c389ec873974db5daebdaef24c5efe7815d40430059ea9e032c168c461ee7868f
+MISC metadata.xml 910 BLAKE2B 8faa891eaa254f955ca28de28073d7d3d2026a5fad5a296e0f196d1e1087f4dd0ec08a4a613c28de345bb4ae626b292e5432640513a35dfed8a031ba5c452a99 SHA512 7721bd73046e7215f409f070ba0eb222ab05b84db6152cece5ac0fa9b1fd6259805b1c241cd515c62ed78567bce4fa5ef2bd3f9a01a5f2ad2ab7cc2d15ebde3b
diff --git a/dev-games/libmt_client/files/libmt_client-0.1.98-format.patch b/dev-games/libmt_client/files/libmt_client-0.1.98-format.patch
new file mode 100644
index 000000000000..5173853849cc
--- /dev/null
+++ b/dev-games/libmt_client/files/libmt_client-0.1.98-format.patch
@@ -0,0 +1,50 @@
+--- src/mt_client_game.c.old 2015-12-22 08:51:19.858561807 +0100
++++ src/mt_client_game.c 2015-12-22 08:52:48.934904973 +0100
+@@ -56,7 +56,7 @@
+ }
+ else
+ {
+- g_printerr (str_err_function[num]);
++ g_printerr ("%s\n", str_err_function[num]);
+ exit (-1);
+ }
+ }
+@@ -110,27 +110,27 @@
+ }
+
+ str_err_function[LIBMT_CLIENT_FUNCTION_INIT] =
+- _("libmt_client_function INIT : not initialised\n");
++ _("libmt_client_function INIT : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_GAME_INIT] =
+- _("libmt_client_function GAME_INIT : not initialised\n");
++ _("libmt_client_function GAME_INIT : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_MAKE_BID] =
+- _("libmt_client_function MAKE_BID : not initialised\n");
++ _("libmt_client_function MAKE_BID : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_MAKE_CHIEN] =
+- _("libmt_client_function MAKE_CHIEN : not initialised\n");
++ _("libmt_client_function MAKE_CHIEN : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_NOT_MAKE_CHIEN] =
+- _("libmt_client_function NOT_MAKE_CHIEN : not initialised\n");
++ _("libmt_client_function NOT_MAKE_CHIEN : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_CHOOSE_CARD] =
+- _("libmt_client_function CHOOSE_CARD : not initialised\n");
++ _("libmt_client_function CHOOSE_CARD : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_DRAW] =
+- _("libmt_client_function DRAW : not initialised\n");
++ _("libmt_client_function DRAW : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_REMOVE_CARD] =
+- _("libmt_client_function REMOVE CARD : not initialised\n");
++ _("libmt_client_function REMOVE CARD : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_ACK_REPLAY] =
+- _("libmt_client_function ACK REPLAY : not initialised\n");
++ _("libmt_client_function ACK REPLAY : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_LOST_CONNECTION] =
+- _("libmt_client_function LOST CONNECTION : not initialised\n");
++ _("libmt_client_function LOST CONNECTION : not initialised");
+ str_err_function[LIBMT_CLIENT_FUNCTION_NORMAL_CLOSE] =
+- _("libmt_client_function NORMAL CLOSE : not initialised\n");
++ _("libmt_client_function NORMAL CLOSE : not initialised");
+
+ return (0);
+ }
diff --git a/dev-games/libmt_client/libmt_client-0.1.98.ebuild b/dev-games/libmt_client/libmt_client-0.1.98.ebuild
new file mode 100644
index 000000000000..4b26528a061a
--- /dev/null
+++ b/dev-games/libmt_client/libmt_client-0.1.98.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="backend library for the maitretarot clients"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot"
+RDEPEND=${DEPEND}
+
+src_prepare () {
+ epatch "${FILESDIR}"/${P}-format.patch
+}
diff --git a/dev-games/libmt_client/metadata.xml b/dev-games/libmt_client/metadata.xml
new file mode 100644
index 000000000000..64ab523b4aaf
--- /dev/null
+++ b/dev-games/libmt_client/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+ MaitreTarot is a Tarot card game. Understand a game like freecell or poker,
+ nothing to do with astrology. Tarot is rather a French game.
+
+ MaitreTarot is made of two kind of elements:
+
+ * A server, that knows the rules, that gives the cards to the clients, that
+ counts the points, and everything else that a server should do.
+ * Clients. The main idea is to have differents clients. Some would be
+ clients for human players, with a GUI (gtk+, qt, web, ncurses, win32...). And
+ some would be AI. That would allow users to play with AI, and even AI
+ tournaments could be played in order to know the best AI!
+ </longdescription>
+</pkgmetadata>