summaryrefslogtreecommitdiff
path: root/dev-games/hdl_dump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/hdl_dump
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/hdl_dump')
-rw-r--r--dev-games/hdl_dump/Manifest4
-rw-r--r--dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch45
-rw-r--r--dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild31
-rw-r--r--dev-games/hdl_dump/metadata.xml8
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-games/hdl_dump/Manifest b/dev-games/hdl_dump/Manifest
new file mode 100644
index 000000000000..345f06bcfb99
--- /dev/null
+++ b/dev-games/hdl_dump/Manifest
@@ -0,0 +1,4 @@
+AUX hdl_dump-0.8.6.20060901-fortify.patch 1443 BLAKE2B 4be87a044e2a7bb55aa3054b9fd11f041e13035c5de36598d9d10877a55f67a7156b82cc0819b299d9f80a8b27d91f09b95b044bdc0d4b09c6b77a5b9f09cfcb SHA512 7af0cd2dfcc0b3535cdfd6d8e3b85e475187e89ef46801f2306032d9c8b7d5bdfaf2b5b1f399d8dc3d54251fc0fb063ee7778f3cf2e70f0c685ae81ceafb17e9
+DIST hdl_dumx-0.8.6-20060901-src.tar.bz2 156322 BLAKE2B f05ce1ccc10e23980ec24d75555bc609b913b0d2c32606b2eb616a7721d7c11ceee6c2a3b8e8bd9020c1747dfb8d514d4924798a512e11e606249c5a8725c45d SHA512 c54c72c3f4d57ca8f3299c0b6044ec5376504f7b7a4c7977d71b996bc8d98577ffa868891e1a599aebbe58b8d3ccf2513c5cf8a47350c0b0f53fd21a0e64bbc8
+EBUILD hdl_dump-0.8.6.20060901.ebuild 699 BLAKE2B f783e29e98f7119afc6b42ea32344908acd496854abe48e6a786fdd5e6768d981bfa2bc0e02c8b7ed0ba49c2bb1aee1bc2032dc6fb59d240f40cd7ec351ffa2f SHA512 e93e9db6acf82a74d6960cc4d52ad670e007c9845eaa85bb92f5359ee56279e52f4c2e4601714ee689f957ff667578c9c769582199467f81f99e400824aa5df0
+MISC metadata.xml 249 BLAKE2B fe8f0b0b97ffe948e8c6fd17a3e9b5d2a5662e5e3f34e7e6ca95d12cbe91ad39b1d138a923972ac44b337b5d962e4604e129efc3a6d91ce67fb354499dcbceaa SHA512 738a899d8e0481cb1c3401c552abae01b86e30a2aaefd1efac7f381b7ae246a3d8467b3e871b5a8f1fe697c59c38bdfb7f62e59ed828646b2c9239049f6a0f02
diff --git a/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch b/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch
new file mode 100644
index 000000000000..96f85d4609af
--- /dev/null
+++ b/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/340145
+
+fix buffer overflows in path handling. these defines should only be used
+with host paths, so bumping them up to a larger value should be fine.
+
+--- a/common.h
++++ b/common.h
+@@ -35,7 +35,8 @@
+ C_START
+
+ #if !defined (MAX_PATH)
+-# define MAX_PATH 128
++/* This needs to be at least 256 bytes -- see iin_gi_probe_path */
++# define MAX_PATH 1024
+ #endif
+
+
+--- a/osal.h
++++ b/osal.h
+@@ -62,7 +62,8 @@ typedef struct
+ # define OSAL_HANDLE_INIT { -1 } /* file descriptor */
+ # define OSAL_IS_OPENED(x) ((x).desc != -1)
+
+-# define MAX_PATH 256
++/* This needs to be at least 256 bytes -- see iin_gi_probe_path */
++# define MAX_PATH 1024
+
+ #endif
+ typedef /*@special@*/ /*@only@*/ /*@out@*/ osal_handle_t* osal_handle_p_t;
+
+the magic field is 32 bytes, so strcpy-ing 32 bytes will add a 33rd NUL char.
+this isn't a problem in practice as the 33rd char is "unknown_0x02", but let's
+fix the issue anyways.
+
+--- a/apa.c
++++ b/apa.c
+@@ -1270,7 +1270,7 @@ apa_initialize_ex (hio_t *hio)
+ set_u32 (&header.length, 128 * 1024 * 2);
+ set_u16 (&header.type, 0x0001);
+ set_ps2fs_datetime (&header.created, time (NULL));
+- strcpy (header.mbr.magic, "Sony Computer Entertainment Inc.");
++ memcpy (header.mbr.magic, "Sony Computer Entertainment Inc.", 32);
+ header.mbr.unknown_0x02 = 0x02;
+ set_ps2fs_datetime (&header.mbr.created, time (NULL));
+ set_u32 (&header.checksum, apa_partition_checksum (&header));
diff --git a/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild b/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild
new file mode 100644
index 000000000000..470f81f67c20
--- /dev/null
+++ b/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="game installer for playstation 2 HD Loader"
+HOMEPAGE="http://www.psx-scene.com/hdldump/"
+SRC_URI="http://www.psx-scene.com/hdldump/hdl_dumx-${MY_PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fortify.patch #340145
+ sed -i \
+ -e "s/-O0 -g/${CFLAGS}/" \
+ -e "s/@\$(CC)/$(tc-getCC)/" \
+ -e '/LDFLAGS =/d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin hdl_dump
+ dodoc AUTHORS CHANGELOG README TODO
+}
diff --git a/dev-games/hdl_dump/metadata.xml b/dev-games/hdl_dump/metadata.xml
new file mode 100644
index 000000000000..b5988412c8c3
--- /dev/null
+++ b/dev-games/hdl_dump/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>