summaryrefslogtreecommitdiff
path: root/dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild')
-rw-r--r--dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild b/dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..89175cf28dff
--- /dev/null
+++ b/dev-games/flatzebra/flatzebra-0.1.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generic game engine for 2D double-buffering animation"
+HOMEPAGE="http://perso.b2b2c.ca/~sarrazip/dev/batrachians.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^doc_DATA =/s/^/NOTHANKS/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}