summaryrefslogtreecommitdiff
path: root/dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild')
-rw-r--r--dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild b/dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild
new file mode 100644
index 000000000000..21842002c4b5
--- /dev/null
+++ b/dev-erlang/riak_pb/riak_pb-2.2.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Riak Protocol Buffers messages"
+HOMEPAGE="https://github.com/basho/riak_pb"
+SRC_URI="https://github.com/basho/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ppc ~sparc x86"
+
+DEPEND=">=dev-erlang/protobuffs-0.9.0
+ >=dev-erlang/hamcrest-0.1.0_p20160709
+ >=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md RELNOTES.md )