summaryrefslogtreecommitdiff
path: root/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-erlang/protobuffs/protobuffs-0.8.2.ebuild')
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
new file mode 100644
index 000000000000..380ee4f02da5
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.markdown )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}