summaryrefslogtreecommitdiff
path: root/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-erlang/protobuffs/protobuffs-0.8.2.ebuild')
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
new file mode 100644
index 000000000000..380ee4f02da5
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.markdown )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}