summaryrefslogtreecommitdiff
path: root/dev-erlang/idna
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-erlang/idna
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-erlang/idna')
-rw-r--r--dev-erlang/idna/Manifest4
-rw-r--r--dev-erlang/idna/files/idna-remove-unicode_util_compat.diff103
-rw-r--r--dev-erlang/idna/idna-6.0.0.ebuild25
-rw-r--r--dev-erlang/idna/metadata.xml10
4 files changed, 142 insertions, 0 deletions
diff --git a/dev-erlang/idna/Manifest b/dev-erlang/idna/Manifest
new file mode 100644
index 000000000000..145661f1b089
--- /dev/null
+++ b/dev-erlang/idna/Manifest
@@ -0,0 +1,4 @@
+AUX idna-remove-unicode_util_compat.diff 3444 BLAKE2B 7b45729159ff91beb386208c02eb726d32f760cd63537cd80521be56803c5bfcc12299093ff4c8a3fea27b46b016063a73b050c0ece6617ae3709101dc5ad9bb SHA512 25a2f9333711184ddf192fb0d7ca98d50bbb74628572c0e7a144078489561fcc2d2a3a9a7424d84cac74f87a7b370f0fc4947ab1ff01fc079577be272d94631e
+DIST idna-6.0.0.tar.gz 740802 BLAKE2B 91bc6ee4031450b00659415125e8cec3f034f988bb7d307d323b0a7ca53450d42f0e84a044ccb6c198107c253b70e54466e77b2b0b4e9dd7f7051da49872be33 SHA512 59f8996199f7e3391b1da1b8fb1ebb70e442838eab1f26af9a8a8545f3e1b9f72f0afd65108272a51d846b34e0e8abe9623f10c89156ebca3d87b6b3eb63a066
+EBUILD idna-6.0.0.ebuild 630 BLAKE2B b80cece428cb749792616b07512ba954cb40ddd988fb54429a9501bc462123f2c6f25842a0624be2914eecf83e8f7dbd76d65ca625ea0655a0e0471054629073 SHA512 c560fe1e3270eda9550e76073bc47ba9161e17c02e165d70ef29f8ffecb45589b28e4eb11e13eaea3e64aa1a5b0e86860a431190d1b79a9478d419ee75ff7ab8
+MISC metadata.xml 303 BLAKE2B 41a70964ffafdfb045b03f004f44ad1a97dd523d630072c47259d9d755909e35de535c65632eeda33585d78b2d0768b9e22667edc0a935b5329f516001ff0e31 SHA512 fb1fc68c17d6f9553e06234f732921f0f57822eaab2b32903cebc2f8439c02ed4aba58b1d32069accec4f1ac1add5a24d158f293ae1ff1e28c2e95d062d2da06
diff --git a/dev-erlang/idna/files/idna-remove-unicode_util_compat.diff b/dev-erlang/idna/files/idna-remove-unicode_util_compat.diff
new file mode 100644
index 000000000000..d369cefbf2a6
--- /dev/null
+++ b/dev-erlang/idna/files/idna-remove-unicode_util_compat.diff
@@ -0,0 +1,103 @@
+diff --git a/rebar.config b/rebar.config
+index 84fd954..cd02013 100644
+--- a/rebar.config
++++ b/rebar.config
+@@ -1,3 +1,3 @@
+ {erl_opts, []}.
+
+-{deps, [{unicode_util_compat, "0.4.1"}]}.
++{deps, []}.
+diff --git a/rebar.config.script b/rebar.config.script
+deleted file mode 100644
+index d2bce94..0000000
+--- a/rebar.config.script
++++ /dev/null
+@@ -1,11 +0,0 @@
+-IsRebar3 = erlang:function_exported(rebar3, main, 1),
+-Rebar2Deps = [{unicode_util_compat, ".*",
+- {git, "https://github.com/benoitc/unicode_util_compat.git",
+- {tag, "0.3.1"}}}
+- ],
+-case IsRebar3 of
+- true ->
+- CONFIG;
+- false ->
+- lists:keyreplace(deps, 1, CONFIG, {deps, Rebar2Deps})
+-end.
+diff --git a/rebar.lock b/rebar.lock
+deleted file mode 100644
+index 15fc8a1..0000000
+--- a/rebar.lock
++++ /dev/null
+@@ -1,6 +0,0 @@
+-{"1.1.0",
+-[{<<"unicode_util_compat">>,{pkg,<<"unicode_util_compat">>,<<"0.4.1">>},0}]}.
+-[
+-{pkg_hash,[
+- {<<"unicode_util_compat">>, <<"D869E4C68901DD9531385BB0C8C40444EBF624E60B6962D95952775CAC5E90CD">>}]}
+-].
+diff --git a/src/idna.erl b/src/idna.erl
+index 5f010b3..32b1745 100644
+--- a/src/idna.erl
++++ b/src/idna.erl
+@@ -333,7 +333,7 @@ lowercase_list([], true) ->
+ lowercase_list([], false) ->
+ throw(unchanged);
+ lowercase_list(CPs0, Changed) ->
+- case unicode_util_compat:lowercase(CPs0) of
++ case unicode_util:lowercase(CPs0) of
+ [Char|CPs] when Char =:= hd(CPs0) -> [Char|lowercase_list(CPs, Changed)];
+ [Char|CPs] -> append(Char,lowercase_list(CPs, true));
+ [] -> lowercase_list([], Changed)
+@@ -346,9 +346,9 @@ lowercase_bin(CP1, <<CP2/utf8, Bin/binary>>, Changed)
+ when CP1 < 128, CP2 < 256 ->
+ [CP1|lowercase_bin(CP2, Bin, Changed)];
+ lowercase_bin(CP1, Bin, Changed) ->
+- case unicode_util_compat:lowercase([CP1|Bin]) of
++ case unicode_util:lowercase([CP1|Bin]) of
+ [CP1|CPs] ->
+- case unicode_util_compat:cp(CPs) of
++ case unicode_util:cp(CPs) of
+ [Next|Rest] ->
+ [CP1|lowercase_bin(Next, Rest, Changed)];
+ [] when Changed ->
+@@ -357,7 +357,7 @@ lowercase_bin(CP1, Bin, Changed) ->
+ throw(unchanged)
+ end;
+ [Char|CPs] ->
+- case unicode_util_compat:cp(CPs) of
++ case unicode_util:cp(CPs) of
+ [Next|Rest] ->
+ [Char|lowercase_bin(Next, Rest, true)];
+ [] ->
+@@ -374,7 +374,7 @@ append(GC, Str) when is_list(GC) -> GC ++ Str.
+
+
+ characters_to_nfc_list(CD) ->
+- case unicode_util_compat:nfc(CD) of
++ case unicode_util:nfc(CD) of
+ [CPs|Str] when is_list(CPs) -> CPs ++ characters_to_nfc_list(Str);
+ [CP|Str] -> [CP|characters_to_nfc_list(Str)];
+ [] -> []
+diff --git a/src/idna_context.erl b/src/idna_context.erl
+index afcb814..a09ff1f 100644
+--- a/src/idna_context.erl
++++ b/src/idna_context.erl
+@@ -28,7 +28,7 @@ valid_contextj(Label, Pos) ->
+ valid_contextj(16#200c, Label, Pos) ->
+ if
+ Pos > 0 ->
+- case unicode_util_compat:lookup(lists:nth(Pos, Label)) of
++ case unicode_util:lookup(lists:nth(Pos, Label)) of
+ #{ ccc := ?virama_combining_class } -> true;
+ _ ->
+ valid_contextj_1(Label, Pos)
+@@ -38,7 +38,7 @@ valid_contextj(16#200c, Label, Pos) ->
+ end;
+
+ valid_contextj(16#200d, Label, Pos) when Pos > 0 ->
+- case unicode_util_compat:lookup(lists:nth(Pos, Label)) of
++ case unicode_util:lookup(lists:nth(Pos, Label)) of
+ #{ ccc := ?virama_combining_class } -> true;
+ _ -> false
+ end;
diff --git a/dev-erlang/idna/idna-6.0.0.ebuild b/dev-erlang/idna/idna-6.0.0.ebuild
new file mode 100644
index 000000000000..243854541657
--- /dev/null
+++ b/dev-erlang/idna/idna-6.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang IDNA implementation"
+HOMEPAGE="https://github.com/benoitc/erlang-idna"
+SRC_URI="https://github.com/benoitc/erlang-idna/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/erlang-21.0"
+
+DOCS=( CHANGELOG README.md )
+
+S="${WORKDIR}/erlang-idna-${PV}"
+
+# Removes dependency to workaround for older erlang versions.
+# Patch from https://github.com/benoitc/erlang-idna/pull/31
+PATCHES=( "${FILESDIR}/idna-remove-unicode_util_compat.diff" )
diff --git a/dev-erlang/idna/metadata.xml b/dev-erlang/idna/metadata.xml
new file mode 100644
index 000000000000..7d0a22a4d4fe
--- /dev/null
+++ b/dev-erlang/idna/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ejabberd@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">benoitc/erlang-idna</remote-id>
+ </upstream>
+</pkgmetadata>