summaryrefslogtreecommitdiff
path: root/dev-erlang/esip/esip-1.0.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-erlang/esip/esip-1.0.30.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-erlang/esip/esip-1.0.30.ebuild')
-rw-r--r--dev-erlang/esip/esip-1.0.30.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-erlang/esip/esip-1.0.30.ebuild b/dev-erlang/esip/esip-1.0.30.ebuild
new file mode 100644
index 000000000000..60f5a1713cd4
--- /dev/null
+++ b/dev-erlang/esip/esip-1.0.30.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="ProcessOne SIP server component"
+HOMEPAGE="https://github.com/processone/esip"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ >=dev-erlang/fast_tls-1.1.2
+ >=dev-erlang/stun-1.0.29
+ >=dev-erlang/p1_utils-1.0.16"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_fix_include_path stun
+
+ # ebin contains lonely .gitignore file asking for removal.
+ rm -r "${S}/ebin" || die
+}