summaryrefslogtreecommitdiff
path: root/dev-erlang/epam/epam-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-erlang/epam/epam-1.0.6.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-erlang/epam/epam-1.0.6.ebuild')
-rw-r--r--dev-erlang/epam/epam-1.0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-erlang/epam/epam-1.0.6.ebuild b/dev-erlang/epam/epam-1.0.6.ebuild
new file mode 100644
index 000000000000..6056b365b81a
--- /dev/null
+++ b/dev-erlang/epam/epam-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar user
+
+DESCRIPTION="epam for ejabberd to help with PAM authentication support"
+HOMEPAGE="https://github.com/processone/epam"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+pkg_setup() {
+ enewgroup "${PN}"
+}
+
+src_install() {
+ rebar_src_install
+
+ local epam_path="$(get_erl_libs)/${P}/priv/bin/epam"
+ fowners root:"${PN}" "${epam_path}"
+ fperms 4750 "${epam_path}"
+}