summaryrefslogtreecommitdiff
path: root/dev-erlang/epam/epam-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-erlang/epam/epam-1.0.4.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-erlang/epam/epam-1.0.4.ebuild')
-rw-r--r--dev-erlang/epam/epam-1.0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-erlang/epam/epam-1.0.4.ebuild b/dev-erlang/epam/epam-1.0.4.ebuild
new file mode 100644
index 000000000000..faddaeab02f0
--- /dev/null
+++ b/dev-erlang/epam/epam-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar user
+
+DESCRIPTION="epam for ejabberd to help with PAM authentication support"
+HOMEPAGE="https://github.com/processone/epam"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+pkg_setup() {
+ enewgroup "${PN}"
+}
+
+src_install() {
+ rebar_src_install
+
+ local epam_path="$(get_erl_libs)/${P}/priv/bin/epam"
+ fowners root:"${PN}" "${epam_path}"
+ fperms 4750 "${epam_path}"
+}