summaryrefslogtreecommitdiff
path: root/dev-embedded
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
commit304c1973bececee173a9d6235a2c364466d309e1 (patch)
tree11acd7542e4ef6dd961bb3c64dae01ba417212e6 /dev-embedded
parent4d643b662f77ef9cc872089cad15cf5e7e1f70f2 (diff)
gentoo auto-resync : 09:02:2024 - 23:33:52
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/Manifest.gzbin9400 -> 9401 bytes
-rw-r--r--dev-embedded/raspberrypi-utils/Manifest3
-rw-r--r--dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch77
-rw-r--r--dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild4
4 files changed, 83 insertions, 1 deletions
diff --git a/dev-embedded/Manifest.gz b/dev-embedded/Manifest.gz
index 61a33f429de5..bfe8242740a6 100644
--- a/dev-embedded/Manifest.gz
+++ b/dev-embedded/Manifest.gz
Binary files differ
diff --git a/dev-embedded/raspberrypi-utils/Manifest b/dev-embedded/raspberrypi-utils/Manifest
index ff4b73ab41f9..d6db15fc9033 100644
--- a/dev-embedded/raspberrypi-utils/Manifest
+++ b/dev-embedded/raspberrypi-utils/Manifest
@@ -1,3 +1,4 @@
+AUX raspberrypi-utils-werror.patch 2504 BLAKE2B 31dcf606fb47fd459e2ae1908917a5584a46c042612988f82a8c62139446cd452d450be3f17f4602907052327ec1d5b841ba5c6d89065f482707610bfa5ebcfc SHA512 7d0ea3573394b91af0d1904b378991545c6537f939543b724b5c642c50c2c9330af7938b323667be3043c507d6da68e7bff6072a06ac4a1d0e20d4f465fa1175
DIST raspberrypi-utils-0_p20240203.tar.gz 122695 BLAKE2B 178b84b5210ba47a51e9815710b05d3916981f5413986cefcdb621420c9e9ab33b67026ea95692c6aff900dd2c31302059eb39aae32267b88cf765a7575f8bed SHA512 bdbe47d87a4bcd0d37ea4567e95e41fbc8240f5ffbc805d4a1f576060535af13e272b262ddad87dac0f9ea43b8b2ff9092378e67de080bd651701435b4c67008
-EBUILD raspberrypi-utils-0_p20240203.ebuild 885 BLAKE2B fe77be9912a80fa068367e9668d875d8b2a71ce77fa73162c10e5b9704425fa6f618bfbbf212ac2e30f583b9567a0fb9836ac59f88a4a93a9d6495aba22a1f02 SHA512 f0ed87ab172ec2f8750e05f7833fa9bc78e09ee880d6b9b023c7beceeb37a3a7266cb4f2538d7a1312988d4e551862ae3476147a462a54576a375c05e9321042
+EBUILD raspberrypi-utils-0_p20240203.ebuild 932 BLAKE2B 3291e890e5f7a13f291b6820f696645f91046ec0f942b20e441990c06e9e3bf3f22b30f620feb32b7a81939e8c14cdb504f4e40ea5383ebf0e5f67fc44404936 SHA512 b394008fa8f8babcc146ce286a22e174c5cd56921ebc5403343e7a78845ba343e3ce8da60170fb7070b9030a6b6a50aa05fe9dace1dd2a65036d823e511002b6
MISC metadata.xml 330 BLAKE2B e7285a8024f322ab0f8c8789bdfa2601c046c776c24c7e411ef9c5be424bd3000c2749d47e5cac3c0f5f870decd1106e019b279c229dc27de238cfad8f2e4979 SHA512 f0cd8ffa52484dc9ff84623ddf51d9f4c696c1d7cc357042bfae47b7da62eb94336703d038b1511138b40a0b545d96b4a4faa8e5b2787d0bcdac3b9259c883fc
diff --git a/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch b/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch
new file mode 100644
index 000000000000..ddfce08d0407
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch
@@ -0,0 +1,77 @@
+https://github.com/raspberrypi/utils/pull/69
+
+From 0bbef73e2f1df17c793152895cabac452a49981f Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Tue, 6 Feb 2024 21:36:08 +0000
+Subject: [PATCH] build: Only enable -Werror for debug builds
+
+-Werror is very unhelpful for distributions and end users as newer
+compilers will raise warnings that the maintainers may not see. The
+warnings should get reported upstream, but they shouldn't block users
+from using the software.
+
+Rather than drop the flag entirely, I have enabled it only for debug
+builds, e.g. -DCMAKE_BUILD_TYPE=Debug.
+
+Signed-off-by: James Le Cuirot <chewi@gentoo.org>
+---
+ dtmerge/CMakeLists.txt | 2 +-
+ eeptools/CMakeLists.txt | 2 +-
+ pinctrl/CMakeLists.txt | 2 +-
+ vclog/CMakeLists.txt | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/dtmerge/CMakeLists.txt b/dtmerge/CMakeLists.txt
+index f63648b..357889f 100644
+--- a/dtmerge/CMakeLists.txt
++++ b/dtmerge/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ #set project name
+ project(dtmerge)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror>)
+
+ if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions (-ffunction-sections)
+diff --git a/eeptools/CMakeLists.txt b/eeptools/CMakeLists.txt
+index 3438255..90fc284 100644
+--- a/eeptools/CMakeLists.txt
++++ b/eeptools/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ #set project name
+ project(eeptools)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror>)
+
+ if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions (-ffunction-sections)
+diff --git a/pinctrl/CMakeLists.txt b/pinctrl/CMakeLists.txt
+index 2178ee4..70427f2 100644
+--- a/pinctrl/CMakeLists.txt
++++ b/pinctrl/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 3.10...3.27)
+ include(GNUInstallDirs)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror -pedantic")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror> -pedantic)
+
+ #set project name
+ project(pinctrl)
+diff --git a/vclog/CMakeLists.txt b/vclog/CMakeLists.txt
+index 611f9dc..b7e57eb 100644
+--- a/vclog/CMakeLists.txt
++++ b/vclog/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 3.10...3.27)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror -pedantic")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror> -pedantic)
+
+ #set project name
+ project(vclog)
+--
+2.43.0
+
diff --git a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
index 1c13aaaa6bdb..4668331a2b0a 100644
--- a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
+++ b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
@@ -27,6 +27,10 @@ RDEPEND="
S="${WORKDIR}/utils-${COMMIT}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-werror.patch
+)
+
src_configure() {
local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
cmake_src_configure