summaryrefslogtreecommitdiff
path: root/dev-embedded/uisp/uisp-20050207-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/uisp/uisp-20050207-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/uisp/uisp-20050207-r1.ebuild')
-rw-r--r--dev-embedded/uisp/uisp-20050207-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-embedded/uisp/uisp-20050207-r1.ebuild b/dev-embedded/uisp/uisp-20050207-r1.ebuild
new file mode 100644
index 000000000000..2a92a428cdd4
--- /dev/null
+++ b/dev-embedded/uisp/uisp-20050207-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Tool for programming AVR microcontroller through the parallel port"
+HOMEPAGE="https://savannah.nongnu.org/projects/uisp"
+SRC_URI="https://savannah.nongnu.org/download/uisp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "/^DOC_INST_DIR/s:/[^/]*$:/${PF}:" Makefile.in || die
+ cd src
+ epatch "${FILESDIR}"/mega-48-88-168.patch
+ sed -i -e 's: -Werror::' Makefile.in || die
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* || die
+}