summaryrefslogtreecommitdiff
path: root/dev-embedded/u-boot-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-embedded/u-boot-tools
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest2
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2020.04-r1.ebuild72
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2020.04-r2.ebuild74
3 files changed, 148 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index bea0e99aad3a..7f10c81a753a 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -5,5 +5,7 @@ DIST u-boot-2020.01.tar.bz2 14716125 BLAKE2B a2860f74cd3b147d39ed55ba4745e0400e1
DIST u-boot-2020.04.tar.bz2 15065656 BLAKE2B 29cf8be6027ce46e3bf3fae9b6736e6aba46dba2904112f845d79f50b52b7c7ff3437c71dac6ab22d112347467fb5baaa3ec421cb842ba3ae9b547e4f8378d03 SHA512 e04fe54883149123730605b084324ac0d1d72ce6913467bbe587a5a2675bcf7bb393405d9a446dc0c64ba42abc1e862ae5a132e9e51aa7390e2e9fce045af8d8
EBUILD u-boot-tools-2019.10.ebuild 1222 BLAKE2B c17b706fffbefc963eaf5483def5aaabde40546687f401c4cab51d90bdd02f89b370ed38ae6da6ef989aa749a1ae0d9a5a94a9e19fc394e9e9ea6976bce6755b SHA512 36c8f97437c04b8dc56fd3072ac7d5fb2edebb55763e2a211492535ca3f14db5a828127f93df133a46f63d83d7a69a21f86a0b54de040f46cdb5511e07c7b53b
EBUILD u-boot-tools-2020.01.ebuild 1224 BLAKE2B fb067f2dc615ffb5c880808a6b42b918e38774b8ea8f5e83d6a7ce9f8ffba4d8f7368dbcdf8307703719c81cb14ace49b2fe65d587eddacef792733b3b89460d SHA512 98112d8af5fdb4340f7816d9cfbc6c143c6488e163018347e80f6d7b2ab51177e98b6fdf39e424f9af74890756820d9913bec255f075f5d6b7e25dc439cecb66
+EBUILD u-boot-tools-2020.04-r1.ebuild 1418 BLAKE2B 47150da7dc25e27851e9878eb57305d26d839931068c119a06b08be3cf945c7bc1e1f274d699f8862955bfbb91116f873124db75d7c045be70f3cb662c42eceb SHA512 c2fffc12e9aae0aa5adcb566fadf253829aecf959c3d1332db52f94dfbf734676a456d35034aeb1061708ea5c2c30395b6a24b664a48700d94331b1a9531d6cb
+EBUILD u-boot-tools-2020.04-r2.ebuild 1451 BLAKE2B ea15d35458b7651acf34b5cf94622994ed1d9e0f0ba5aa1dcb1187466709f355272c7266b5b29a19ddb969ed793e4c3ea380f59f06b73a36355705a3af8391f3 SHA512 14ac06fc98a0fcbfd09272dc5a77a67f567f40d5fc9053a78ad990a70b17c4619a2a2c10ace3fbfe88936fd38af6d4f300d3ed36892a406914507a0ed66c45ff
EBUILD u-boot-tools-2020.04.ebuild 1178 BLAKE2B d948706033a0fd9c8b72514fb34a46a09035d54f8f8b526902a3b06a68d52581e82cb74c85507853cf1f2615dc7ee923b554a784f717119e43d849e3af09b540 SHA512 eb0e9487f7bf8ac89d4baaa7b2380ef18cf42581ae0675ef8f36021388c65432e43e4051458b7784ac8a9157244b05847b3812d06a043a1f12c428b6fb403729
MISC metadata.xml 247 BLAKE2B e46b8f2d053251af5cb591bb2ee5e35089c4e8174ee2e7a3c504db23f844b65083d4a3e5198da3977ad3e98b67cab2e0de686a3c62009b487c1e64785a8ff65d SHA512 15df289e0f962f564551f61ada3cfef0311f6af639887def780bf5ad3be105515c8d24c950ff340ed35d89b9cd994af3540322b684c5dec3b43ec6bb0041aa4e
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r1.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r1.ebuild
new file mode 100644
index 000000000000..32ca29504b4b
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
+ scripts/kconfig/lxdialog/check-lxdialog.sh \
+ scripts/kconfig/Makefile \
+ tools/Makefile || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+
+ emake \
+ V=1 \
+ CC="${CC}" \
+ HOSTCC="${CC}" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-only_defconfig
+
+ emake \
+ V=1 \
+ NO_SDL=1 \
+ HOSTSTRIP=: \
+ STRIP=: \
+ CC="${CC}" \
+ HOSTCC="${CC}" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_test() { :; }
+
+src_install() {
+ cd tools || die
+ dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}"/doc/mkimage.1
+}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r2.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r2.ebuild
new file mode 100644
index 000000000000..ac9b538b8410
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2020.04-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
+ scripts/kconfig/lxdialog/check-lxdialog.sh \
+ scripts/kconfig/Makefile \
+ tools/Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC PKG_CONFIG
+}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+
+ emake \
+ V=1 \
+ AR="${AR}" \
+ CC="${CC}" \
+ HOSTCC="${CC}" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-only_defconfig
+
+ emake \
+ V=1 \
+ NO_SDL=1 \
+ HOSTSTRIP=: \
+ STRIP=: \
+ AR="${AR}" \
+ CC="${CC}" \
+ HOSTCC="${CC}" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_test() { :; }
+
+src_install() {
+ cd tools || die
+ dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}"/doc/mkimage.1
+}