summaryrefslogtreecommitdiff
path: root/dev-embedded/u-boot-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
commitd3fc35858ba4bc0c8038a8c536246b00fe648358 (patch)
tree416e79067bd12fc0b43e12f1b73ee15a62b8a5bf /dev-embedded/u-boot-tools
parent2512faa12f58e69a2f3e27e13e10fd0aef3ab384 (diff)
gentoo auto-resync : 29:08:2022 - 10:46:12
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest4
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild80
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild1
3 files changed, 2 insertions, 83 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index b5ded0b8fb11..02df95bbc25e 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,5 +1,3 @@
-DIST u-boot-2022.04.tar.bz2 17772787 BLAKE2B 5d2035130c0631f8f1b7f7963bedf71578a66994e3950eb103a404a08e85686cd971ba51e8172093ccb75d975101024bf2a94d4064763ad57ad8950c11092319 SHA512 113056e542db049eea3b1d1ccbbe52c79539a2f9bb6129d284ec9200dcffec7bd5969821913a9899631575b80991c84ad01bc845b4bba614e42e54466d9f0d64
DIST u-boot-2022.07.tar.bz2 18087759 BLAKE2B bb78c7ccd56f12ebc622fb73d29cbf0a5db9d421133b191a6591845b4842b111145d2df649bae69011284bd468b8219ee0df20b61660ea4ec52006a93e14f09d SHA512 e1b3621dafac876c644ffb3d24b6e2380f5a78454c420a5b17d174e3f0b57731a95cfbff28ae7d0af4493f4bbf8d21e7f9236d61bb2414ed12295332b3d557b6
-EBUILD u-boot-tools-2022.04.ebuild 1546 BLAKE2B a91038ee3eeed987d2f2345c83c976c83712b27b54598815ee3f6a6661ff3616247e3156b85301aa5b6cbc26b5459a36d0ab008629538cf39f7d2b0c749b9def SHA512 d46bd2cf77587e5af7985da97ee8e6bc61513d33ec2cc2ed5605164ea194c40ccb6e327645fa307244d7f91fc034f8e74af5cf54a06d665f20f89d94cec3b98c
-EBUILD u-boot-tools-2022.07.ebuild 1546 BLAKE2B a91038ee3eeed987d2f2345c83c976c83712b27b54598815ee3f6a6661ff3616247e3156b85301aa5b6cbc26b5459a36d0ab008629538cf39f7d2b0c749b9def SHA512 d46bd2cf77587e5af7985da97ee8e6bc61513d33ec2cc2ed5605164ea194c40ccb6e327645fa307244d7f91fc034f8e74af5cf54a06d665f20f89d94cec3b98c
+EBUILD u-boot-tools-2022.07.ebuild 1561 BLAKE2B b7e6e1bd690440c0af7085fa7055eff9823a8aafe179dd6b4412c93988a2abe04f52f152fe3eb2d8aa6f2feac311892e61c84d106db90645d2b6d1e082167a86 SHA512 3e9a1d07ad0767d96042ed5e4b7145ac5f1264de2d5a748c8a22052fb941a162a4d968e08ab848fbc0d13c4eec955118d0f07d5c08ce80c70f5ce16d61a3edb6
MISC metadata.xml 451 BLAKE2B 8634c7b8cd333dadddeb3622fbe298d19b5a470b85743717fb972e310869ee2a897110a9fd7b5781de016ba9a8c9baf7c6b5ed89279e98f086a4d326cdcce807 SHA512 981503c1d3a7dd42ca141b00a29fac43eb379603140767f0e0de94f54fd4180b498cebea56692c017ab7dbf9a2afdfb222edc5942c58429490456c064b5fa41d
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
deleted file mode 100644
index 7bf924633a93..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="https://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 ~riscv x86"
-IUSE="envtools"
-
-RDEPEND="dev-libs/openssl:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
- scripts/kconfig/{g,m,n,q}conf-cfg.sh \
- scripts/kconfig/Makefile \
- tools/Makefile || die
-}
-
-src_configure() {
- tc-export AR BUILD_CC CC PKG_CONFIG
- tc-export_build_env
-}
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
-
- local myemakeargs=(
- V=1
- AR="${AR}"
- CC="${CC}"
- HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${BUILD_CFLAGS} ${BUILD_CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${BUILD_LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" tools-only_defconfig
-
- emake "${myemakeargs[@]}" \
- NO_SDL=1 \
- HOSTSTRIP=: \
- STRIP=: \
- CONFIG_ENV_OVERWRITE=y \
- $(usex envtools envtools tools-all)
-}
-
-src_test() { :; }
-
-src_install() {
- cd tools || die
-
- if ! use envtools; then
- dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
- fi
-
- dobin env/fw_printenv
-
- dosym fw_printenv /usr/bin/fw_setenv
-
- insinto /etc
- doins env/fw_env.config
-
- doman ../doc/mkimage.1
-}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild
index 7bf924633a93..4b8ceb9f6cd6 100644
--- a/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2022.07.ebuild
@@ -19,6 +19,7 @@ IUSE="envtools"
RDEPEND="dev-libs/openssl:="
DEPEND="${RDEPEND}"
BDEPEND="
+ dev-lang/swig
sys-devel/bison
sys-devel/flex
virtual/pkgconfig