summaryrefslogtreecommitdiff
path: root/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
deleted file mode 100644
index cacfea709295..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~ppc64 x86"
-IUSE=""
-
-DEPEND="
- sys-devel/flex
- sys-devel/bison
-"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=("${FILESDIR}"/${P}-musl-ulong.patch)
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
-
- emake \
- V=1 \
- HOSTCC="$(tc-getCC)" \
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
- HOSTLDFLAGS="${LDFLAGS}" \
- tools-only_defconfig
-
- emake \
- V=1 \
- NO_SDL=1 \
- HOSTSTRIP=: \
- STRIP=: \
- HOSTCC="$(tc-getCC)" \
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
- HOSTLDFLAGS="${LDFLAGS}" \
- CONFIG_ENV_OVERWRITE=y \
- tools-all
-}
-
-src_test() { :; }
-
-src_install() {
- cd tools || die
- dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
- dobin env/fw_printenv
- dosym fw_printenv /usr/bin/fw_setenv
- insinto /etc
- doins env/fw_env.config
- doman "${S}"/doc/mkimage.1
-}