summaryrefslogtreecommitdiff
path: root/dev-embedded/stlink/stlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/stlink/stlink-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/stlink/stlink-9999.ebuild')
-rw-r--r--dev-embedded/stlink/stlink-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-embedded/stlink/stlink-9999.ebuild b/dev-embedded/stlink/stlink-9999.ebuild
new file mode 100644
index 000000000000..479ca67cd591
--- /dev/null
+++ b/dev-embedded/stlink/stlink-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils udev
+
+DESCRIPTION="stm32 discovery line linux programmer"
+HOMEPAGE="https://github.com/texane/stlink"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/texane/stlink.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/texane/stlink/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/libusb:1
+ >=dev-libs/glib-2.32.0:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
+ -DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
+ -DLIB_INSTALL_DIR:PATH="$(get_libdir)"
+ )
+
+ cmake-utils_src_configure
+}