summaryrefslogtreecommitdiff
path: root/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild')
-rw-r--r--dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild b/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
index c317c061b57d..3aa25dab19f1 100644
--- a/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
+++ b/dev-embedded/sdcc/sdcc-4.3.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/sdcc/code/trunk/sdcc"
@@ -110,6 +110,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924691
+ # https://sourceforge.net/p/sdcc/bugs/3725/
+ filter-lto
+
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache