summaryrefslogtreecommitdiff
path: root/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild')
-rw-r--r--dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..13da6435290b
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+MY_PN="${PN/-libftdi/}"
+MY_P="${MY_PN}-${PV}"
+
+TABFILE="libd2xx_table.so"
+TABFILEDIR="libftdi/lib_table"
+
+DESCRIPTION="Library which includes a table of VIDs and PIDs of Ever UPS devices"
+HOMEPAGE="http://www.ever.com.pl"
+SRC_URI="http://www.ever.com.pl/pl/pliki/${MY_P}-x86.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd "${TABFILEDIR}"
+
+ # Wipe out precompiled binary
+ emake clean
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ ftditabfile="${TABFILEDIR}/${TABFILE}"
+ dolib.so ${ftditabfile}
+}