summaryrefslogtreecommitdiff
path: root/dev-embedded/platformio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-embedded/platformio
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-embedded/platformio')
-rw-r--r--dev-embedded/platformio/Manifest3
-rw-r--r--dev-embedded/platformio/platformio-5.2.4-r1.ebuild80
-rw-r--r--dev-embedded/platformio/platformio-5.2.4.ebuild2
3 files changed, 83 insertions, 2 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 46ee397ef857..eb8ba14ee3ab 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,3 +1,4 @@
DIST platformio-5.2.4.tar.gz 254337 BLAKE2B e29b69a514b5f3bc6faefb15dd4e3195152d74b763961c35c33cd9e44bcd430920dc2f4d553244c2ac1bb83d745c006c67d2d52973fa07562c8b98d8e74a2ac3 SHA512 f90c1f5d9dcada99c610003b26ccaa4e08c214757d0c26daeea3cae006a02179aea1eb0bc656751913d0b2c4161195b1afe9ab0eaab5ad594ff986f6b56728f8
-EBUILD platformio-5.2.4.ebuild 2357 BLAKE2B 088d560ae0b4451ba4dc0dbc0fa9a1296523d98804eb89e20787e0cb33f1037f482de5f883c20b73856a47d2ed12bf0033421784e234a2431a144bf3c62e3786 SHA512 310411670f92ec4579f5690dd42584e8d48014170e8ff5f87e084b7aa35936014068a511484ba5244438a61adba967b2dbb8b1d9c40e0ea12f563042e309c8f6
+EBUILD platformio-5.2.4-r1.ebuild 2499 BLAKE2B c44903b8f9b69f5c6056ff3daa9aa6693bf4de3885071c82e35a824c0340d425413c54fe80597c4f7675bf67753716b27c252c1c56d4e00af0412496586bdc7a SHA512 95fe995e292bbc7fc9dcb26e6992d5f4415d7643c5afcccf6735c0467ad6650dd2aa52f493342b446f5a725789d464599171dd4dcf0553c14929d6596d0010d4
+EBUILD platformio-5.2.4.ebuild 2362 BLAKE2B 19f53c899a5ae8af72fc92cea34ca287d011b539e2516ad591b4a3ee7ab7f7c6cab31d84c42972088c05b82a974e72196da564d7798ba010b9e89dd65750ebc8 SHA512 0097bcfe69144912e94599b83cec2cba90c41ae6eed4afb43b11ae4eea8cedbb52878b7d5e9642c4bd2128fbe21a387052dbbcf29e17646840d7c728f4e01d17
MISC metadata.xml 249 BLAKE2B 0d8c6b8e9873180a796f77c5194270389ae642d0d888d7fa1bbada89861dc1ba1bd9f238acd76f7a07a3eb694ac8bdb19927012814a03ed8d3e87f40676979d1 SHA512 1ac8ddbe837cb8db85bb6e4ee59a6e98554c04231c54cb5158fbe7dda3230aaeb02ab66ff374f5bb348e84159588b0740c43acd99ed590939db70bbd2f15d265
diff --git a/dev-embedded/platformio/platformio-5.2.4-r1.ebuild b/dev-embedded/platformio/platformio-5.2.4-r1.ebuild
new file mode 100644
index 000000000000..10226f631dec
--- /dev/null
+++ b/dev-embedded/platformio/platformio-5.2.4-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 udev
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-core-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/aiofiles-0.8.0[${PYTHON_USEDEP}]
+ dev-python/ajsonrpc[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.17[${PYTHON_USEDEP}]
+ >=dev-python/uvicorn-0.16[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
+ ')
+ virtual/udev"
+DEPEND="virtual/udev"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+
+# This list could be refined a bit to have individual tests which need network
+# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
+EPYTEST_IGNORE=(
+ # Requires network access
+ tests/test_builder.py
+ tests/package/test_manager.py
+ tests/package/test_manifest.py
+ tests/commands/test_platform.py
+ tests/commands/test_test.py
+ tests/commands/test_ci.py
+ tests/commands/test_init.py
+ tests/commands/test_lib.py
+ tests/commands/test_lib_complex.py
+ tests/commands/test_boards.py
+ tests/commands/test_check.py
+ tests/test_ino2cpp.py
+ tests/test_maintenance.py
+ tests/test_misc.py
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Allow newer versions of zeroconf, Bug #831181.
+ sed -i '/zeroconf/s/==/>=/' "${S}"/setup.py || die
+ default
+}
+
+src_install() {
+ distutils-r1_src_install
+ udev_dorules scripts/99-platformio-udev.rules
+}
diff --git a/dev-embedded/platformio/platformio-5.2.4.ebuild b/dev-embedded/platformio/platformio-5.2.4.ebuild
index 21416a0b2fad..29472eceaf9b 100644
--- a/dev-embedded/platformio/platformio-5.2.4.ebuild
+++ b/dev-embedded/platformio/platformio-5.2.4.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}"/${PN}-core-${PV}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
RDEPEND="
$(python_gen_cond_dep '