summaryrefslogtreecommitdiff
path: root/dev-embedded/platformio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-embedded/platformio
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-embedded/platformio')
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-5.2.3-r2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 1e12ebd45d9f..f25e389bd016 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -2,4 +2,5 @@ DIST platformio-5.1.1.tar.gz 215305 BLAKE2B a7854138dec1b5b58c4f715dde98a273ed08
DIST platformio-5.2.3.tar.gz 252483 BLAKE2B f60b83f6647333d42b5d864ea468c8104dcd5a83085a6d52f456a21792d9c94641a60f698c2a606ddd7d7b3a588723831f35ac0d3027cb0ff8b8226dabe3b62c SHA512 c11f58a984b15a3363cd29bf9a0234c1ffc772cc153310d420037416bb8834cb2b74899ccb465d69db862cc088cfcb17dcbc7d919f690b6e836dec982d5b136b
EBUILD platformio-5.1.1.ebuild 1111 BLAKE2B 3b68dbeea9ad0e22fc6a145ee3f8673ad408a05cda92f1ecb5859711f5705e850f8730ff54981605133aef63549d8c15c78c0b5bfcd7d14430c3506e6cc50af5 SHA512 7462e3edcce9dfe99d285bc72b13316109054020cd32f85181fd67624481c98c924f972c046d6fd3fba3ba8cbb334c549d9121d4bb63b753fd670e1047d5d3d0
EBUILD platformio-5.2.3-r1.ebuild 2182 BLAKE2B 2754ac9911d499bef789ad3dc570293939a5e6a5f981761815457865e363a9099e2604c6e2a22890612309685f149f59383127846813849d3ffb957881473be4 SHA512 2de9212f45fc9cd251bd62b9909f99dab3a224ffcb9e306f4d1bd7d1bd06ede532aa49e4ac8428e808c8bcdf54c3e04f64a86d2de61587882e6803c6e61ab6d5
+EBUILD platformio-5.2.3-r2.ebuild 2315 BLAKE2B e6fa4088a90e73fe978e5e1ed2f2a07df0e165a676e236be60b0303cb19cef9b5a5dd09bf3b7a362298849bfe97ec3905c79b9b36919d1b377244c8dd2ee01e3 SHA512 164cafc40c53c7f74035e21a76249b09d2249f4c484c11b88b888b315b0f0a057f233a0490b514152e864b6c02703514b1f53f5a4f9084f8fc5b61e6c57d8467
MISC metadata.xml 249 BLAKE2B 0d8c6b8e9873180a796f77c5194270389ae642d0d888d7fa1bbada89861dc1ba1bd9f238acd76f7a07a3eb694ac8bdb19927012814a03ed8d3e87f40676979d1 SHA512 1ac8ddbe837cb8db85bb6e4ee59a6e98554c04231c54cb5158fbe7dda3230aaeb02ab66ff374f5bb348e84159588b0740c43acd99ed590939db70bbd2f15d265
diff --git a/dev-embedded/platformio/platformio-5.2.3-r2.ebuild b/dev-embedded/platformio/platformio-5.2.3-r2.ebuild
new file mode 100644
index 000000000000..d1a8b6826686
--- /dev/null
+++ b/dev-embedded/platformio/platformio-5.2.3-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 udev
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-core-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ =dev-python/aiofiles-0.7.0*[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ =dev-python/uvicorn-0.15*[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ dev-python/zeroconf[${PYTHON_USEDEP}]
+ ')
+ virtual/udev"
+DEPEND="virtual/udev"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+
+# This list could be refined a bit to have individual tests which need network
+# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
+EPYTEST_IGNORE=(
+ # Requires network access
+ tests/test_builder.py
+ tests/package/test_manager.py
+ tests/package/test_manifest.py
+ tests/commands/test_platform.py
+ tests/commands/test_test.py
+ tests/commands/test_ci.py
+ tests/commands/test_init.py
+ tests/commands/test_lib.py
+ tests/commands/test_lib_complex.py
+ tests/commands/test_boards.py
+ tests/commands/test_check.py
+ tests/test_ino2cpp.py
+ tests/test_maintenance.py
+ tests/test_misc.py
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ udev_dorules scripts/99-platformio-udev.rules
+}