summaryrefslogtreecommitdiff
path: root/dev-embedded/platformio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-embedded/platformio
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-embedded/platformio')
-rw-r--r--dev-embedded/platformio/Manifest2
-rw-r--r--dev-embedded/platformio/platformio-4.1.0-r1.ebuild42
-rw-r--r--dev-embedded/platformio/platformio-4.1.0.ebuild38
3 files changed, 43 insertions, 39 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 83d4e1ebbe9a..3bd07e1d9359 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,3 +1,3 @@
DIST platformio-4.1.0.tar.gz 157907 BLAKE2B e90d2b155121cd2be0b0d77a7a196e7fe03580083444056d06a86a343166c920cd1ac6252a0003acee4de5d3933fead939b8be8d67233e93c05537511344e27b SHA512 e4d6c29ebb8fb1b2b556affbc1a50ec84d12e878bb7e6cfb253861eb5429236d8226d1a29f1a3812c0aa2c5b4895f0354184a9cb28c300db2e2e5a2ededb82fe
-EBUILD platformio-4.1.0.ebuild 1180 BLAKE2B cd22a0a6810f93bd713b8e2297eacf5b8aaef91d05f40b5abac79c8750023c28a51e48f9dd9001bd651bdc204122156d01e9e5be04660e3c11af0812d550d27f SHA512 7d39f20df7bd1c512d0f737e88651d721896af77f72c3ccff3c8731f96202c18199d0f96cd5d350590ab8be4529e5253fb57d8a2b3901fcc959b7aa80e70f3b0
+EBUILD platformio-4.1.0-r1.ebuild 1357 BLAKE2B 7276de22e430c12a051ed6f32de4780cd39a53bf694b66fee451aac629f9bdaafb0580cb7ae28b3dbe5169f2e665900c66af75f560e1b6e26a3d87cfaeb6f602 SHA512 80a4906938d243661d747f547116ecd0f674b28830fc727c30d28289f1cea8768b13c76d7bc488e75733508167336647a37972d87c7275fd5efe0851ca4aeab2
MISC metadata.xml 248 BLAKE2B 946598a9bc9f658d98c3282fd6affeb3834a4b6071beca852a2f2381d5c17799b6ed17ed427a8f6e10fb3f715cdf2aad9e4fed2886f0dd67dacfdffcd5137f80 SHA512 89d637e180ed3a2c2096be2210633dc5df0760a7d6acd7b2d2ad8a06d473943ee86bad7e74c7df238a50168d1da8044471713e9b044007b9c2f4eb604fb710d5
diff --git a/dev-embedded/platformio/platformio-4.1.0-r1.ebuild b/dev-embedded/platformio/platformio-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..0c28bb271d22
--- /dev/null
+++ b/dev-embedded/platformio/platformio-4.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ <dev-python/bottle-0.13[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/click-5[${PYTHON_MULTI_USEDEP}]
+ <dev-python/click-8[${PYTHON_MULTI_USEDEP}]
+ dev-python/colorama[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_MULTI_USEDEP}]
+ <dev-python/requests-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_MULTI_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_MULTI_USEDEP}]
+ <dev-python/marshmallow-3[${PYTHON_MULTI_USEDEP}]
+ ')"
diff --git a/dev-embedded/platformio/platformio-4.1.0.ebuild b/dev-embedded/platformio/platformio-4.1.0.ebuild
deleted file mode 100644
index 29d4e2ad7b49..000000000000
--- a/dev-embedded/platformio/platformio-4.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="An open source ecosystem for IoT development"
-HOMEPAGE="https://platformio.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- <dev-python/bottle-0.13[${PYTHON_USEDEP}]
- >=dev-python/click-5[${PYTHON_USEDEP}]
- <dev-python/click-8[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3[${PYTHON_USEDEP}]
- <dev-python/pyserial-4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
- <dev-python/semantic_version-3[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
- <dev-python/tabulate-1[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
- <dev-python/pyelftools-1[${PYTHON_USEDEP}]
- >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
- <dev-python/marshmallow-3[${PYTHON_USEDEP}]"