summaryrefslogtreecommitdiff
path: root/dev-embedded/platformio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-embedded/platformio
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/platformio')
-rw-r--r--dev-embedded/platformio/Manifest2
-rw-r--r--dev-embedded/platformio/platformio-3.5.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index fa9287e72b56..f37abc6d59e2 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,3 +1,5 @@
DIST platformio-3.5.3.tar.gz 96791 BLAKE2B 4b17ccec4a192704cbd185ed42eb6214cfa54a072f6d089f96c608eec7815bd3046b12f7e84355055b5026600b22c4f1c720b12caea4e281479d4c381fe8ec4f SHA512 4c5b5b0a0c4d6942f91ffcb4317149cdbdba857f17b07ad3f47db9abd97615eafbd310d0f1a2c389b485922af1df6f3a6d7831bce1f92a53540b00998c859247
+DIST platformio-3.5.4.tar.gz 97742 BLAKE2B 5fcc652358ea5788977836a6ee0fe204633e2748afc5cbb6924e8200c0115c92a778c0c919178f05a9656f21eb2b17f4e15b0de5ea06fbade936d8b59bb12431 SHA512 2d2af5133648a9b2070abb5d39d27a7292865b99cf690c587f4c80d5e97d429eaa3b037b07a1afcf199df730fe96a0dfecb4ff45ffd21d286f80d5d265e9a85e
EBUILD platformio-3.5.3.ebuild 983 BLAKE2B 914ec00f360676c67cb37673c5a3ff2c4075de9b4056eedb9471dd964574881ba6df8ddd1b1edb04356781be366f7ec76bd8b82262745a3a33ac43198243e028 SHA512 72d8261e807850c4709dab0cde6aae59b08d7e5ad3b81969232a098b741bbc863e7196c5bd54e6e7be389be42f595a4c8d3a9ca5a99cd45bd488b942c0126a38
+EBUILD platformio-3.5.4.ebuild 983 BLAKE2B 914ec00f360676c67cb37673c5a3ff2c4075de9b4056eedb9471dd964574881ba6df8ddd1b1edb04356781be366f7ec76bd8b82262745a3a33ac43198243e028 SHA512 72d8261e807850c4709dab0cde6aae59b08d7e5ad3b81969232a098b741bbc863e7196c5bd54e6e7be389be42f595a4c8d3a9ca5a99cd45bd488b942c0126a38
MISC metadata.xml 248 BLAKE2B 946598a9bc9f658d98c3282fd6affeb3834a4b6071beca852a2f2381d5c17799b6ed17ed427a8f6e10fb3f715cdf2aad9e4fed2886f0dd67dacfdffcd5137f80 SHA512 89d637e180ed3a2c2096be2210633dc5df0760a7d6acd7b2d2ad8a06d473943ee86bad7e74c7df238a50168d1da8044471713e9b044007b9c2f4eb604fb710d5
diff --git a/dev-embedded/platformio/platformio-3.5.4.ebuild b/dev-embedded/platformio/platformio-3.5.4.ebuild
new file mode 100644
index 000000000000..a4d3b719d1c2
--- /dev/null
+++ b/dev-embedded/platformio/platformio-3.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ <dev-python/arrow-1[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ <dev-python/click-6[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/lockfile-0.13[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.5.0[${PYTHON_USEDEP}]"