summaryrefslogtreecommitdiff
path: root/dev-embedded/picotool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /dev-embedded/picotool
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'dev-embedded/picotool')
-rw-r--r--dev-embedded/picotool/Manifest4
-rw-r--r--dev-embedded/picotool/metadata.xml11
-rw-r--r--dev-embedded/picotool/picotool-1.1.0.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-embedded/picotool/Manifest b/dev-embedded/picotool/Manifest
new file mode 100644
index 000000000000..1db56472a263
--- /dev/null
+++ b/dev-embedded/picotool/Manifest
@@ -0,0 +1,4 @@
+DIST pico-sdk-1.4.0.tar.gz 959068 BLAKE2B 95c5e61c4d66c345daa4b8aff8e9e2cd90bcc722289ac67c1a18ce00dfa02ef7fb07512a0fdc7558f989746c215cff31979f1ad8a582e20ff2d151fdd109914f SHA512 4be28cf41e5b808a504b4c949f6c3e9fbc425beb4f838a7898bfd78925cc54e0390ff56c036bc7f60a26efac0d6c1bd811b27f7b60a1c8d7bb4750f3fa37690e
+DIST picotool-1.1.0.tar.gz 43994 BLAKE2B 2b8536540be912418be1f0f0d93bb59b9cd4832ce46854478fb0bfbcb4463b49e4806068897a1d665b73ea7a764bf0d96f0a56cde01ef6503c74e1eadc4ed9c2 SHA512 5c13a88e90baed28cf435c7641a84c1c814fc473d57f2502ebb594d84c71bbe82632bf0d24b7755ebfec270d85f4588c488917a224b68c93f40573e956026efc
+EBUILD picotool-1.1.0.ebuild 772 BLAKE2B fae9ed8a76e8486b58097e4a654205cc0cb4bc52b4b437218fe675f0e50cb6bbd5dc82ca8a91540a3bb3ac2dfe3031a461a5504eb598aeaf42c6982b412e2e7e SHA512 a3276b1f33ea36043eaa9c59d599fc039bab4db41a22c4e85ba005e0f42bc067395f59cb06b7f8fd47645d59c7ae7414a1e932a2cc6d078cc46815397974bdb5
+MISC metadata.xml 334 BLAKE2B a4ef9732d149b900ea9297b86aad7f177641715182dfbf8207325ab729a959ff4565f1c2a5bf493a587541be30f35fa98851799bf8c229e10c8d1047b4bc782c SHA512 bcfc16ad40c8668ce3ef74c62e5afc76620038605ae8ab7615382ceead47591631af194adcde959a70b9cc62f0fca4fa28f1e62c8f1ae3cdaafdb5f3aa52f0d3
diff --git a/dev-embedded/picotool/metadata.xml b/dev-embedded/picotool/metadata.xml
new file mode 100644
index 000000000000..a1594d39f6a9
--- /dev/null
+++ b/dev-embedded/picotool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">raspberrypi/picotool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/picotool/picotool-1.1.0.ebuild b/dev-embedded/picotool/picotool-1.1.0.ebuild
new file mode 100644
index 000000000000..87931418a258
--- /dev/null
+++ b/dev-embedded/picotool/picotool-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SDK_PV=1.4.0
+SDK_PN=pico-sdk
+SDK_P=${SDK_PN}-${SDK_PV}
+
+DESCRIPTION="tool for interacting with rp2040 devices and binaries"
+HOMEPAGE="https://github.com/raspberrypi/picotool"
+SRC_URI="
+ https://github.com/raspberrypi/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/raspberrypi/${SDK_PN}/archive/refs/tags/${SDK_PV}.tar.gz -> ${SDK_P}.tar.gz
+"
+
+# picotool (BSD)
+# |- clipp (MIT)
+# |- pico-sdk (BSD)
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPICO_SDK_PATH="${WORKDIR}"/${SDK_P}
+ )
+ cmake_src_configure
+}