summaryrefslogtreecommitdiff
path: root/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild')
-rw-r--r--dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
new file mode 100644
index 000000000000..036812167200
--- /dev/null
+++ b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for uploading files to the filesystem of an ESP8266 running NodeMCU"
+HOMEPAGE="https://github.com/kmpm/nodemcu-uploader"
+SRC_URI="https://github.com/kmpm/nodemcu-uploader/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pyserial-3.4[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py