summaryrefslogtreecommitdiff
path: root/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /dev-embedded/libftdi/libftdi-0.20-r1.ebuild
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'dev-embedded/libftdi/libftdi-0.20-r1.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-0.20-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
index 87f52c9e3e58..8aed5262ba38 100644
--- a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
@@ -7,8 +7,8 @@ PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
inherit cmake-utils python-single-r1
if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
- inherit git-2
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
@@ -20,6 +20,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
IUSE="cxx doc examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:0
cxx? ( dev-libs/boost )
@@ -28,7 +29,10 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-include.patch
+ "${FILESDIR}"/${P}-cmake-version.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -44,12 +48,11 @@ src_prepare() {
-e '/SET(LIB_SUFFIX /d' \
CMakeLists.txt || die
- eapply "${FILESDIR}"/${P}-cmake-{include,version}.patch
- eapply_user
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)