summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-embedded/esptool/esptool-2.3.1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-embedded/esptool/esptool-2.3.1.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-embedded/esptool/esptool-2.3.1.ebuild b/dev-embedded/esptool/esptool-2.3.1.ebuild
new file mode 100644
index 000000000000..3a5259cd84b3
--- /dev/null
+++ b/dev-embedded/esptool/esptool-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-2.5[${PYTHON_USEDEP}]"
+
+RESTRICT="test" # Uses a device connected to the serial port
+
+python_test() {
+ ${EPYTHON} test/test_esptool.py || die
+}