summaryrefslogtreecommitdiff
path: root/dev-embedded/esptool/esptool-2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-embedded/esptool/esptool-2.2.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-embedded/esptool/esptool-2.2.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.2.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-embedded/esptool/esptool-2.2.ebuild b/dev-embedded/esptool/esptool-2.2.ebuild
deleted file mode 100644
index fc375443446a..000000000000
--- a/dev-embedded/esptool/esptool-2.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-2.5[${PYTHON_USEDEP}]"
-
-RESTRICT="test" # Uses a device connected to the serial port
-
-python_test() {
- ${EPYTHON} test/test_esptool.py || die
-}