summaryrefslogtreecommitdiff
path: root/dev-embedded/dc-tool-ip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/dc-tool-ip
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/dc-tool-ip')
-rw-r--r--dev-embedded/dc-tool-ip/Manifest5
-rw-r--r--dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild42
-rw-r--r--dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch22
-rw-r--r--dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch22
-rw-r--r--dev-embedded/dc-tool-ip/metadata.xml14
5 files changed, 105 insertions, 0 deletions
diff --git a/dev-embedded/dc-tool-ip/Manifest b/dev-embedded/dc-tool-ip/Manifest
new file mode 100644
index 000000000000..28989cecfc58
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/Manifest
@@ -0,0 +1,5 @@
+AUX 1.0.4-bfd-update.patch 909 BLAKE2B 02a5b3be9db1c98e01cbda6e75de14bcefa4c8abb4400855be4effa046adfd6382612a1c4c33d2999b8eca45aec40256dcf3c7d864947c3174fe6688a7a092d7 SHA512 a1a24436104012ec5c56028dd4f7b16d9bcf23923d64d3ba14fd9a6b413770d1ccaaa91d56f62e49afbe77bfb0fdc3bb4eeba12d24b547f0f8598a4f3f6ceb8c
+AUX dc-tool-ip-1.0.4-headers.patch 487 BLAKE2B bfe1eee99d73a0a37428fa8015f3b073762b3f295f83066de09e3cf7efd00aa904d16c9f1cd111be7c8eaa41c755a93024fa8e0210f87d7f4be09c0181a1eb31 SHA512 a83b3d0f214de12fc25ef250f106e325d39e78afacb56db31a7f4c6033e8c848b934260c589967cb6fe1751ca401584b1b66f3593b4cbc2d7c2bcc108d8ab4c2
+DIST dcload-ip-1.0.4-src.tar.gz 104758 BLAKE2B 4c8c52077b047da81341a133272a5569de9e6b304942c181da01a617a00243ace2847bbd380ac723710d91dc43d6de134d3a34e083ef9fa61471ba49ce5021f3 SHA512 c58f574bf13dd44a00395060af4c718593471242366d09dddb234490d20a6e0322a2c3853613aa1c8a5269802cf6434407d3f6c62c934e8b66f8fc1e86a12536
+EBUILD dc-tool-ip-1.0.4.ebuild 970 BLAKE2B 58708d998ae1c0eb9cdb8d839d457dba421d6df4f43d5c01e4e2bf14910445db7530db58afff29bb5bda61491657646e7fd6d7c2fa849c755d86960a9d993539 SHA512 3d1960b451f08bb823f5755c2c1d3298579bb1edcc0d9a3f3e2f7df7264fa02b3fbce3a4265d33f2e8ed27a1760086ca6247f1b2ab0bd77bddc1d49d9480bd53
+MISC metadata.xml 403 BLAKE2B 22b3c6edfd0bb8b5b254247b738dd9ceeb30dbd0aeeed3f27ea0c9d0fd375c04c809a042510ebc69f84d668bcbb4e753ab1d518c288b433d9a1e5283da1903b8 SHA512 eeac6ac902c1f8f2ca47e218722772725f9d4f1ad13c2e8807a3262e802b2b3bbcfb184d3ccb0827be26be2b453960e1fcc8b0b9d32936b12aa11c8fd4c67127
diff --git a/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild b/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild
new file mode 100644
index 000000000000..fc9a8492d5ea
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="ethernet program loader for the Dreamcast"
+HOMEPAGE="http://cadcdev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cadcdev/dcload-ip-${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+S=${WORKDIR}/dcload-ip-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-bfd-update.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ append-cppflags -DPACKAGE -DPACKAGE_VERSION #465952
+ sed -i \
+ -e "/^HOSTCC/s:gcc:$(tc-getCC):" \
+ -e "/^HOSTCFLAGS/s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ -e 's:-L/usr/local/dcdev/lib:$(LDFLAGS):' \
+ -e 's:/usr/local/dcdev/include:.:' \
+ Makefile.cfg || die "sed"
+}
+
+src_compile() {
+ emake -C host-src/tool
+}
+
+src_install() {
+ dobin host-src/tool/dc-tool
+ dodoc README NETWORK CHANGES
+ dodoc -r make-cd
+ if use doc ; then
+ dodoc -r example-src
+ fi
+}
diff --git a/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch b/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch
new file mode 100644
index 000000000000..62da02f12e98
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch
@@ -0,0 +1,22 @@
+--- host-src/tool/dc-tool.c.orig 2004-11-13 19:38:50.007151024 -0500
++++ host-src/tool/dc-tool.c 2004-11-13 19:38:58.320887144 -0500
+@@ -431,13 +431,13 @@
+ if ((section->flags & SEC_HAS_CONTENTS) && (section->flags & SEC_LOAD)) {
+ printf("Section %s, ",section->name);
+ printf("lma 0x%x, ",section->lma);
+- printf("size %d\n",section->_raw_size);
+- if (section->_raw_size) {
+- size += section->_raw_size;
+- inbuf = malloc(section->_raw_size);
+- bfd_get_section_contents(somebfd, section, inbuf, 0, section->_raw_size);
++ printf("size %d\n",section->rawsize);
++ if (section->rawsize) {
++ size += section->rawsize;
++ inbuf = malloc(section->rawsize);
++ bfd_get_section_contents(somebfd, section, inbuf, 0, section->rawsize);
+
+- send_data(inbuf, section->lma, section->_raw_size);
++ send_data(inbuf, section->lma, section->rawsize);
+
+ free(inbuf);
+ }
diff --git a/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch b/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch
new file mode 100644
index 000000000000..678278262900
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch
@@ -0,0 +1,22 @@
+--- a/host-src/tool/dc-tool.c
++++ b/host-src/tool/dc-tool.c
+@@ -24,6 +24,7 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #ifdef _WIN32
+ #include <string.h>
+ #include <windows.h>
+--- a/host-src/tool/syscalls.c
++++ b/host-src/tool/syscalls.c
+@@ -24,6 +24,9 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
++#include <arpa/inet.h>
++#include <time.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <utime.h>
diff --git a/dev-embedded/dc-tool-ip/metadata.xml b/dev-embedded/dc-tool-ip/metadata.xml
new file mode 100644
index 000000000000..2244c2885a88
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sh@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cadcdev</remote-id>
+ </upstream>
+</pkgmetadata>