summaryrefslogtreecommitdiff
path: root/dev-dotnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-03 05:45:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-03 05:45:01 +0000
commitab5404adfda90358dfaba11eba5579f3f2b7f186 (patch)
tree1630988ce6622c3df9718fdcb997be6ed282dfd1 /dev-dotnet
parentf69d6e2bc8ae2d4f9fd516b99d1dcbfdb78fa533 (diff)
gentoo auto-resync : 03:02:2024 - 05:45:01
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/Manifest.gzbin4300 -> 4293 bytes
-rw-r--r--dev-dotnet/dotnet-sdk/Manifest2
-rw-r--r--dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.101.ebuild17
3 files changed, 17 insertions, 2 deletions
diff --git a/dev-dotnet/Manifest.gz b/dev-dotnet/Manifest.gz
index a01cdffccefb..3f598a1de002 100644
--- a/dev-dotnet/Manifest.gz
+++ b/dev-dotnet/Manifest.gz
Binary files differ
diff --git a/dev-dotnet/dotnet-sdk/Manifest b/dev-dotnet/dotnet-sdk/Manifest
index 057e8080b5ae..1ea24d89d76d 100644
--- a/dev-dotnet/dotnet-sdk/Manifest
+++ b/dev-dotnet/dotnet-sdk/Manifest
@@ -3,5 +3,5 @@ DIST dotnet-sdk-8.0.100-prepared-gentoo-amd64.tar.xz 1714535960 BLAKE2B fd6027b8
DIST dotnet-sdk-8.0.101-prepared-gentoo-amd64.tar.xz 1734234148 BLAKE2B 6fe6b9db8e8399d741c1c7c4b09f7047519fc61e452cc5b319a7e8070acf75685d409741a6fec6f020355a1e003585832c4900dd852d0554d4a456cdb9876598 SHA512 f2f07c647c607d02fc19eb045fa98224636ea5ba79cf9b2b8c28a1c0cbc77cc57bf5886268e94684ddaf5e3895c6c82fa62db11d53d7b8ffd1d31a0371eb4613
DIST dotnet-sdk-8.0.101-prepared-gentoo-musl-amd64.tar.xz 1736552596 BLAKE2B f533603b2d18aedb0c2715b0597973342cab0927f41215f93b6e139df7b666ad32d3cf92866388329d0a5ccd9b169c242a4d9179e03c14856f2572a1363d693b SHA512 0bf9c83fdd310425cb553b798357d0cb9a16608f1341f149a84acf66aa16ec4ff6f81d047c84c06f610d3a861e522c78005b63cec63f78e7e1eebdc80b8ec5a2
EBUILD dotnet-sdk-8.0.100-r2.ebuild 4363 BLAKE2B 7d272fa2b99574cc801bffbd7dd66ba8b4c9513b86f5b1cdd1c99e3f6c9c497215d553dd37681c48bbeb36e0729706c75881f9b11c92728b4d1edec7c35738c3 SHA512 b0bf62358782766203a41805ed1a0e88b1cca1ab4e8f08c72fccb4c797d9b8a8764ba7a7affec4fffce735b1eef6f4e6f6dd3e5bdc2b05964d3a22a2488a9d96
-EBUILD dotnet-sdk-8.0.101.ebuild 4259 BLAKE2B c87cfe316950196fdad7f1c51c269d2c99916ab7065cf17b6b489e80e6d8b288858aa6a03ee3f1aa6457829bc99b22a71c6c86b090404ddf03dc2fad82cd143f SHA512 a61113d4f375fa2081cb5eabf877365aa330dffbc140a8616817ae36bece9043fdfd8cacb544d894672e5fd6730d43ea2cb1e99d2a36bb7167b11713a8782851
+EBUILD dotnet-sdk-8.0.101.ebuild 4823 BLAKE2B 32dd11d66ae344cfddb1cd75c07a3b48118403d771d51c71ea2e376ed86f06638cec020aaab338ec52e4101b9468b8d0dc7e5faa43317b085057c0e482dc70f4 SHA512 8f95159682c532a251529c8c09652f437f1c586ad6416c654d6998b468bb8d07b728d619fe975ad4fd4f12b2e21269639a48ca85158b55d4bf1fc832342f2381
MISC metadata.xml 518 BLAKE2B f9733bd3b6b343126c400ce35dc7e4e57421a6643219341c4beab83d47beb1182306f3d0c5f1e7ff0854fd49818b2c6af37598170b88e2eb82b62d478735abf0 SHA512 940830b1208c39e4cfd72817d399156b027e5ac51dcc7bb983c9ec973f8f2ef76e440a2d358d15f7a2e185c42ae98c986210224f1477923967e3dc70eb0cfde9
diff --git a/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.101.ebuild b/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.101.ebuild
index 7595aa29a8ac..1662f5f5ee6c 100644
--- a/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.101.ebuild
+++ b/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.101.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Pre-build (and distribution preparation)
# Build the tarball:
# git clone --depth 1 -b v8.0.1 https://github.com/dotnet/dotnet dotnet-sdk-8.0.1
# cd dotnet-sdk-8.0.1
@@ -11,6 +12,11 @@
# tar -acf dotnet-sdk-8.0.101-prepared-gentoo-amd64.tar.xz dotnet-sdk-8.0.1
# Upload dotnet-sdk-8.0.101-prepared-gentoo-amd64.tar.xz
+# Build ("src_compile")
+# To learn about arguments that are passed to the "build.sh" script see:
+# https://github.com/dotnet/source-build/discussions/4082
+# User variable: GENTOO_DOTNET_BUILD_VERBOSITY - set other verbosity log level.
+
EAPI=8
COMMIT=b27976e5a6850466ee5b4ce24f91ee93bef645f7
@@ -20,7 +26,7 @@ RUNTIME_SLOT="${SDK_SLOT}.1"
LLVM_MAX_SLOT=17
PYTHON_COMPAT=( python3_{10..12} )
-inherit check-reqs flag-o-matic llvm python-any-r1
+inherit check-reqs flag-o-matic llvm multiprocessing python-any-r1
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
@@ -140,12 +146,21 @@ src_compile() {
# The "source_repository" should always be the same.
local source_repository="https://github.com/dotnet/dotnet"
+ local verbosity="${GENTOO_DOTNET_BUILD_VERBOSITY:-minimal}"
ebegin "Building the .NET SDK ${SDK_SLOT}"
local -a buildopts=(
--clean-while-building
--source-repository "${source_repository}"
--source-version "${COMMIT}"
+
+ --
+ -maxCpuCount:"$(makeopts_jobs)"
+ -verbosity:"${verbosity}"
+ -p:ContinueOnPrebuiltBaselineError=true
+ -p:LogVerbosity="${verbosity}"
+ -p:MinimalConsoleLogOutput=false
+ -p:verbosity="${verbosity}"
)
bash ./build.sh "${buildopts[@]}"
eend ${?} || die "build failed"