summaryrefslogtreecommitdiff
path: root/dev-dotnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-dotnet
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/Manifest.gzbin1396 -> 1572 bytes
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest5
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild48
-rw-r--r--dev-dotnet/dotnet-sdk-bin/metadata.xml15
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-dotnet/Manifest.gz b/dev-dotnet/Manifest.gz
index cb90ece45d6d..6a33fb0e67f2 100644
--- a/dev-dotnet/Manifest.gz
+++ b/dev-dotnet/Manifest.gz
Binary files differ
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
new file mode 100644
index 000000000000..e5a668badc33
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -0,0 +1,5 @@
+DIST dotnet-sdk-5.0.301-linux-arm.tar.gz 138735656 BLAKE2B c23732749f67bd2ca63cadba9bcb3f5abd4e10d00fed441825e6a59f9d3a3e663101502e5557dd94e737443cc9bbab0d5dbe8f7ebdbde54586596ec5c520a64f SHA512 89663ffb22299ad626d3f1d5129e493fb8784e6ed854b128a364407a060eec2979cd7d3c9e4f3df8e47ccb72b98ff8b18e8d53c7fb65b3455faa7344f67417a2
+DIST dotnet-sdk-5.0.301-linux-arm64.tar.gz 136933875 BLAKE2B 6c48c8a2d47ba5bed47e6176d10e273ec996686cb5a4d5b3239098ff23d44526091f7eae1ce762a2eb2f6f31420cafda84471b936082469eadc8c62aa0dcd8bf SHA512 56e233b8f35abe80984bc8a60028f4f8dbc8543313a0711045ef13c693e11e706ee4809574518f57910ec2c93bed896da32760c8143a298556dc25478caca90f
+DIST dotnet-sdk-5.0.301-linux-x64.tar.gz 142255332 BLAKE2B 172888e2eb78d2f768cff6a7e99d6473b469b7cbde74a4eab63e601d85bad118be374f330a413a9b6b3e6773340bdaef8ead4ed54a194189a50cac6b61fac556 SHA512 81cd7a3550a262d5c907030677429fa9a1cb515071274931ab760bd8bb2a14f40c9384c8757e1c1aa681b1de22035f16bf20b41ed208becd054cc9bb1f620322
+EBUILD dotnet-sdk-bin-5.0.301.ebuild 1348 BLAKE2B 1a3fcf60fee6bc0054330f1f1e5522203a83402f82558499cb6c8fefb47419b617e155018f3dfebf25974bbb3c1caa5dedc1ddcdc483fd47de62f55e5eeec2f8 SHA512 43b1f9c46ebda1e582fae02be5fe24c9299351c0529446465fd8164bf36e3917f82890d8a3a95f0036f0d0e1ebdcf750ef47d648e9c055d05c6f937277595cfa
+MISC metadata.xml 408 BLAKE2B 3b2965b7ad096773a4fd2a03a72348752113139fa8d8e67712bb1ffda24e8382c6cb6b7a769025435ff3d40b3bb5e3c5a8e335c1596d19293df667a766392eb3 SHA512 54d50447795d371c68a6ad407bc6f6a7dd010c075f8d24856cbe2535ae8398a732edd0479444c15f1e8aeb8df82abdaa834477c0b0aa9b8ac3367ed4c7675eab
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
new file mode 100644
index 000000000000..ef420c241e6d
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="5.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/metadata.xml b/dev-dotnet/dotnet-sdk-bin/metadata.xml
new file mode 100644
index 000000000000..6905cd2c4766
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <doc>https://docs.microsoft.com/en-us/dotnet/</doc>
+ </upstream>
+ <use>
+ <flag name="dotnet-symlink">
+ Install a dotnet symlink that points to dotnet-bin.
+ </flag>
+ </use>
+</pkgmetadata>