summaryrefslogtreecommitdiff
path: root/dev-dotnet/notify-sharp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-dotnet/notify-sharp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-dotnet/notify-sharp/files')
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch28
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch60
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
new file mode 100644
index 000000000000..44ff05881fb4
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
@@ -0,0 +1,28 @@
+diff -NrU5 notify-sharp-20080912.orig/configure.ac notify-sharp-20080912/configure.ac
+--- notify-sharp-20080912.orig/configure.ac 2008-11-26 21:56:02.000000000 +0100
++++ notify-sharp-20080912/configure.ac 2008-11-26 22:01:08.000000000 +0100
+@@ -34,16 +34,21 @@
+ if test "x$GACUTIL" = "xno"; then
+ AC_MSG_ERROR([You need to install gacutil])
+ fi
+ AC_SUBST(GACUTIL)
+
+-AC_ARG_ENABLE(docs, AC_HELP_STRING([--disable-docs],
+- [Do not build documentation]), with_docs=no, with_docs=yes)
++AC_ARG_ENABLE( [docs],
++ [AC_HELP_STRING( [--enable/disable-docs],
++ [Do (not) build documentation (default=yes)]
++ )],
++ [],
++ [enable_docs=yes]
++)
+
+ MONODOC_REQ_VERSION=1.1.18
+
+-if test "x$with_docs" = "xyes"; then
++if test "x$enable_docs" = "xyes"; then
+ PKG_CHECK_MODULES(MONODOC, monodoc >= $MONODOC_REQ_VERSION,,
+ [AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])])
+ AC_PATH_PROG(MONODOCER, monodocer, no)
+ if test "x$MONODOCER" = "xno"; then
+ AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
new file mode 100644
index 000000000000..28c6316dc5aa
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
@@ -0,0 +1,60 @@
+diff --git a/configure.ac b/configure.ac
+index d2ff635..7200f06 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -71,11 +71,11 @@ GTK_SHARP_REQ_VERSION=2.10.1
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 >= $GTK_SHARP_REQ_VERSION)
+ AC_SUBST(GTK_SHARP_LIBS)
+
+-NDESK_DBUS_REQ_VERSION=0.4
+-NDESK_DBUS_GLIB_REQ_VERSION=0.3
+-PKG_CHECK_MODULES(NDESK_DBUS, ndesk-dbus-1.0 >= $NDESK_DBUS_REQ_VERSION \
+- ndesk-dbus-glib-1.0 >= $NDESK_DBUS_GLIB_REQ_VERSION)
+-AC_SUBST(NDESK_DBUS_LIBS)
++DBUS_SHARP_REQ_VERSION=0.7
++DBUS_SHARP_GLIB_REQ_VERSION=0.5
++PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-1.0 >= $DBUS_SHARP_REQ_VERSION \
++ dbus-sharp-glib-1.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
++AC_SUBST(DBUS_SHARP_LIBS)
+
+ required_assemblies="Mono.Posix"
+
+diff --git a/src/Global.cs b/src/Global.cs
+index eedefbf..a0f80ed 100644
+--- a/src/Global.cs
++++ b/src/Global.cs
+@@ -24,7 +24,7 @@ using System;
+ using System.Reflection;
+ using System.Collections.Generic;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3b39c23..50bbb39 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,7 +7,7 @@ CSFLAGS = \
+ LIBFLAGS = \
+ -r:Mono.Posix \
+ $(GTK_SHARP_LIBS) \
+- $(NDESK_DBUS_LIBS)
++ $(DBUS_SHARP_LIBS)
+
+ CSFILES = \
+ $(srcdir)/Global.cs \
+diff --git a/src/Notification.cs b/src/Notification.cs
+index 09ef83e..e2ab72f 100644
+--- a/src/Notification.cs
++++ b/src/Notification.cs
+@@ -28,7 +28,7 @@ using GLib;
+ using Gdk;
+ using Gtk;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+