summaryrefslogtreecommitdiff
path: root/dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild')
-rw-r--r--dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild b/dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild
new file mode 100644
index 000000000000..d50bbc54ebbb
--- /dev/null
+++ b/dev-dotnet/ndesk-dbus/ndesk-dbus-0.6.1a.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit mono-env
+
+DESCRIPTION="Managed D-Bus Implementation for .NET"
+HOMEPAGE="http://www.ndesk.org/DBusSharp"
+SRC_URI="http://www.ndesk.org/archive/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/mono-1.2.4
+ >=sys-apps/dbus-1
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # mono-4 compat
+ sed -i "s#gmcs#mcs#g" configure || die
+}