summaryrefslogtreecommitdiff
path: root/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-29 07:13:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-29 07:13:27 +0000
commit3ed757b9cee2e1fe2b18c4630539ccd36f0e0f52 (patch)
tree647dcdb9239b18e4313d555b2770bd1c339bcebc /dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild
parentc2d0ee62b92dac1051340f2da2f862794cf1bf9f (diff)
gentoo auto-resync : 29:03:2024 - 07:13:27
Diffstat (limited to 'dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild')
-rw-r--r--dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild b/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild
new file mode 100644
index 000000000000..481fec58dc29
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-nugets/dotnet-runtime-nugets-7.0.15-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=$(ver_cut 1-2)
+NUGETS="
+microsoft.aspnetcore.app.ref@${PV}
+microsoft.aspnetcore.app.runtime.linux-arm@${PV}
+microsoft.aspnetcore.app.runtime.linux-arm64@${PV}
+microsoft.aspnetcore.app.runtime.linux-musl-arm@${PV}
+microsoft.aspnetcore.app.runtime.linux-musl-arm64@${PV}
+microsoft.aspnetcore.app.runtime.linux-musl-x64@${PV}
+microsoft.aspnetcore.app.runtime.linux-x64@${PV}
+microsoft.netcore.app.host.linux-arm@${PV}
+microsoft.netcore.app.host.linux-arm64@${PV}
+microsoft.netcore.app.host.linux-musl-arm@${PV}
+microsoft.netcore.app.host.linux-musl-arm64@${PV}
+microsoft.netcore.app.host.linux-musl-x64@${PV}
+microsoft.netcore.app.host.linux-x64@${PV}
+microsoft.netcore.app.ref@${PV}
+microsoft.netcore.app.runtime.linux-arm@${PV}
+microsoft.netcore.app.runtime.linux-arm64@${PV}
+microsoft.netcore.app.runtime.linux-musl-arm@${PV}
+microsoft.netcore.app.runtime.linux-musl-arm64@${PV}
+microsoft.netcore.app.runtime.linux-musl-x64@${PV}
+microsoft.netcore.app.runtime.linux-x64@${PV}
+"
+
+inherit dotnet-pkg-base
+
+DESCRIPTION=".NET runtime nugets"
+HOMEPAGE="https://dotnet.microsoft.com/"
+SRC_URI="${NUGET_URIS}"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="${PV}/${PV}"
+KEYWORDS="amd64 arm arm64"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ local nuget
+ for nuget in ${NUGETS} ; do
+ nuget_donuget "${DISTDIR}/${nuget/@/.}.nupkg"
+ done
+}