summaryrefslogtreecommitdiff
path: root/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 23:29:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 23:29:13 +0100
commitb544d842bfe55df1b59d40fb8059d5d240e4f42b (patch)
tree092145f89b76ccd50aba38348cb99b802227f5ae /dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
parent20c20eb967a638c833aae1462f149894b2dbd811 (diff)
gentoo auto-resync : 26:09:2023 - 23:29:12
Diffstat (limited to 'dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild')
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
new file mode 100644
index 000000000000..31877c28a815
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=7.0
+NUGETS="
+system.commandline@2.0.0-beta4.22272.1
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION=".NET information tool for Gentoo"
+HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm ~arm64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=(
+ Source/v1/gentoo-dotnet-info-app/GentooDotnetInfo/GentooDotnetInfo.csproj
+)
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ local launcher_dll="/usr/share/${P}/GentooDotnetInfo.dll"
+
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher_portable "${launcher_dll}" gentoo-dotnet-info
+
+ einstalldocs
+}