summaryrefslogtreecommitdiff
path: root/dev-dotnet/coco
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /dev-dotnet/coco
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'dev-dotnet/coco')
-rw-r--r--dev-dotnet/coco/Manifest4
-rw-r--r--dev-dotnet/coco/coco-2014.12.24.ebuild43
-rw-r--r--dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj.patch11
-rw-r--r--dev-dotnet/coco/metadata.xml13
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-dotnet/coco/Manifest b/dev-dotnet/coco/Manifest
new file mode 100644
index 000000000000..7de74936e957
--- /dev/null
+++ b/dev-dotnet/coco/Manifest
@@ -0,0 +1,4 @@
+AUX coco-2014.12.24-Coco-csproj.patch 375 BLAKE2B 1acdf15002c0ca2aff84731c5fbc124acd751c842498a1e755dc14bbe5a95146c0675cf1fb2a7af6db7f97e31aca42c733ca05f8c7173c04eda6390658b3e561 SHA512 0879c975c30b555c150128fdc9aa51b2210af2fa6512097b4dd2a4352d1736239baa02116e554c888145c3856e302bcb56fb3643cd3508b8625f9f47f738f9e9
+DIST coco-2014.12.24.tar.gz 37670 BLAKE2B acd2299e3452d4dac495a0a7f897694791b4abcc0dd7c243771fe8c7084cd9909110c655788844e11fbb576bd95e3596cb890c0ec930c3e4587fd3313082b5cb SHA512 d3b5af1b73b233a8c4b4572db8d65b1c1ffec36e455e4d5fadf1002125433551c833b9574ae03edbe2cd3978fedef41c85667fce82ff2d6ee155c16f778f970e
+EBUILD coco-2014.12.24.ebuild 839 BLAKE2B 8507e6b87f42b686feb601f742d9919e2d6a56fcb4ab0dade3c2365b9aa1d4b411640609282038869c74530d699a5f7fc61ec0394ac6ba17353591ca7ae7937a SHA512 a232c2d2e87316a5b903953fe8626fc2e6be35c18d306e6e9325cacb5912b87f9cb8866603d07b4fcec0eee19a3f533e2d452ed8e75d0034895e57eeb53fb404
+MISC metadata.xml 413 BLAKE2B b2aa9bf31ee00f8e566e236cf74bcb8f66ffba5e17f2d6d59cea01508e1dbdea6096c68af3aa0342035dd173987a7b2466d7ba78bf3ebb92121f026581c95c60 SHA512 465c0da3ea75035edba3f11725dad039b397dcce3e2fb66afcd52f585ed977500af1b2ee0e031ab815ce68ad097d8a4b4ae9a5d26087ec8316f704efd0463a88
diff --git a/dev-dotnet/coco/coco-2014.12.24.ebuild b/dev-dotnet/coco/coco-2014.12.24.ebuild
new file mode 100644
index 000000000000..22b9b0c2c043
--- /dev/null
+++ b/dev-dotnet/coco/coco-2014.12.24.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=6.0
+unset NUGET_PACKAGES
+
+inherit dotnet-pkg
+
+DESCRIPTION="The compiler generator Coco/R for C#"
+HOMEPAGE="https://github.com/boogie-org/coco/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/boogie-org/${PN}.git"
+else
+ SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=( "${S}/Coco.csproj" )
+PATCHES=( "${FILESDIR}/${P}-Coco-csproj.patch" )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/${PN^}" "${PN}"
+
+ einstalldocs
+}
diff --git a/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj.patch b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj.patch
new file mode 100644
index 000000000000..9a3d3b3ec0a5
--- /dev/null
+++ b/dev-dotnet/coco/files/coco-2014.12.24-Coco-csproj.patch
@@ -0,0 +1,11 @@
+--- a/Coco.csproj
++++ b/Coco.csproj
+@@ -13,7 +13,7 @@
+
+ <PropertyGroup>
+ <OutputType>Exe</OutputType>
+- <TargetFrameworks>net6.0;net5.0;netcoreapp3.1</TargetFrameworks>
++ <TargetFrameworks>net6.0</TargetFrameworks>
+ <PackAsTool>true</PackAsTool>
+ <ToolCommandName>coco</ToolCommandName>
+ <GeneratePackageOnBuild>true</GeneratePackageOnBuild>
diff --git a/dev-dotnet/coco/metadata.xml b/dev-dotnet/coco/metadata.xml
new file mode 100644
index 000000000000..1eda8501d942
--- /dev/null
+++ b/dev-dotnet/coco/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/boogie-org/coco/issues/</bugs-to>
+ <remote-id type="github">boogie-org/coco</remote-id>
+ </upstream>
+</pkgmetadata>