summaryrefslogtreecommitdiff
path: root/dev-debug/peda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 20:07:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 20:07:15 +0000
commita4c0eb2444b57e79bce0a088e5936ed71c415e8f (patch)
tree61a990b001109844a226b1fbe33bb38486a88c8e /dev-debug/peda
parente60b61e39bb9b7cbf525baa183a5a19234f335fa (diff)
gentoo auto-resync : 18:01:2024 - 20:07:15
Diffstat (limited to 'dev-debug/peda')
-rw-r--r--dev-debug/peda/Manifest4
-rw-r--r--dev-debug/peda/metadata.xml15
-rw-r--r--dev-debug/peda/peda-1.2.ebuild49
-rw-r--r--dev-debug/peda/peda-9999.ebuild49
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-debug/peda/Manifest b/dev-debug/peda/Manifest
new file mode 100644
index 000000000000..3f63fa6628f4
--- /dev/null
+++ b/dev-debug/peda/Manifest
@@ -0,0 +1,4 @@
+DIST peda-1.2.tar.gz 65331 BLAKE2B 6942b99d714eb1114167b80ba202d86f6dee52cd47c8047b4cb78d4a91f45e1594521440a3318a968e35c5dc56a616393c0837d6f9db5ba41505641a385fb573 SHA512 e69844b8c3a51af96096d97ebfa4a67ac8ff16e4a9e0edb64bbb5e946b1ebeaa56260663718b90145f4191cc25762f3e351a8de92bf9b56f9f1d11389c563c43
+EBUILD peda-1.2.ebuild 994 BLAKE2B 9b514eab43d545b4f8fa5557cbbacb9f81f29ce786958e909f8166cfa7ec01141e7c248741a53335e3d4c87fa79cce095d05538079e71df5b6bfbec772bead37 SHA512 31be421e5fb0d5d40a3b6f3ec517d77c3f23ca157b552ed7b5782625a2242c2342276ddd6300bfa24f1e5921b8c54de621baa253279bd8f973abdfbc7c1b0843
+EBUILD peda-9999.ebuild 996 BLAKE2B f14fa286c2b3a88408f8d5bd481bbaad37a2354502bcdfd30ff666d04e16542854f0322c7b941a7d790200dbd0e774b34052202f61fbb8bdb4b3cdfac9f7f26a SHA512 c4eb08ef6e03a516db871e47b719fb61f64c61899c3ce5d439a398fdff4db360a98878cfa5f9ff5a58c5c1c885757504a749bee99adfd88e0e3d99f4ddf328ff
+MISC metadata.xml 487 BLAKE2B 0e628d9250a7ffad11b26dc82ac257d8128f1656939525478ed90916381a2781a4f6f1c479a3251151bca74f647da0580c9e725ca2b2d4cd89eb96210dcb8a2d SHA512 0420e4ec7a90845c4021ee3ddfbaee208836c7c1fd633d0c5e8767ac346c56fa7de9a6840c7ac698611786bc7245c42e0f5a4b495266462eca1fceca33521e9c
diff --git a/dev-debug/peda/metadata.xml b/dev-debug/peda/metadata.xml
new file mode 100644
index 000000000000..a4d70b1a53ea
--- /dev/null
+++ b/dev-debug/peda/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">longld/peda</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-debug/peda/peda-1.2.ebuild b/dev-debug/peda/peda-1.2.ebuild
new file mode 100644
index 000000000000..9e889d8de922
--- /dev/null
+++ b/dev-debug/peda/peda-1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="Python Exploit Development Assistance for GDB"
+HOMEPAGE="https://github.com/longld/peda"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/longld/peda"
+else
+ SRC_URI="https://github.com/longld/peda/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r lib/ *.py
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "gdb-peda" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/peda.py\"" || die
+
+ dodoc README{,.md}
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-peda <program>\n"
+}
diff --git a/dev-debug/peda/peda-9999.ebuild b/dev-debug/peda/peda-9999.ebuild
new file mode 100644
index 000000000000..dc8b77cb35cd
--- /dev/null
+++ b/dev-debug/peda/peda-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="Python Exploit Development Assistance for GDB"
+HOMEPAGE="https://github.com/longld/peda"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/longld/peda"
+else
+ SRC_URI="https://github.com/longld/peda/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r lib/ *.py
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "gdb-peda" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/peda.py\"" || die
+
+ dodoc README{,.md}
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-peda <program>\n"
+}