summaryrefslogtreecommitdiff
path: root/dev-debug/d-spy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
commit2b2f431a0021b4787ca3c028cefb30ad81347778 (patch)
tree951e0155f53027c8fd29eaba26df4f08292668d5 /dev-debug/d-spy
parentd725480af7cbc67d784e5d96f973fa41e9030123 (diff)
gentoo auto-resync : 19:01:2024 - 20:08:27
Diffstat (limited to 'dev-debug/d-spy')
-rw-r--r--dev-debug/d-spy/Manifest5
-rw-r--r--dev-debug/d-spy/d-spy-1.6.0.ebuild43
-rw-r--r--dev-debug/d-spy/d-spy-1.8.0.ebuild43
-rw-r--r--dev-debug/d-spy/metadata.xml11
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-debug/d-spy/Manifest b/dev-debug/d-spy/Manifest
new file mode 100644
index 000000000000..110330cde73e
--- /dev/null
+++ b/dev-debug/d-spy/Manifest
@@ -0,0 +1,5 @@
+DIST d-spy-1.6.0.tar.xz 215844 BLAKE2B 4811591024d3b599e5e10354db8aa14d5b80bf6fb3c8bfbeadcf5d9c14501af0d00368643cb58eac5ad9452b541743ce3ff9f8376202270f635078876a1012b3 SHA512 7a65bd64320a69eb54077a359381bda35f285b42f4181bf972bc790a8002a773b66c23303e5e94c3dec8c7b9bfc7b8aa60a5ce60f2eb47459ce3dfd634a05703
+DIST d-spy-1.8.0.tar.xz 232944 BLAKE2B cb6f90e9b3d779aa5a76bc93f16e9ae677af029b72451bbb983ffeb06b99a92aa2402ef8b6f6a6c6b4ad4f6ba49a924db37d7e9fc9cb98157a6475a0ec234267 SHA512 49c0ff250a91110014f98453ed6958cf4b5191cc0c8d31c5e63b1408864eaf0906ab3860b0479400a04a8614ee36fe5b9527b179e6346bdb5616cb188d2648f0
+EBUILD d-spy-1.6.0.ebuild 713 BLAKE2B 0be979fc911889f8e9143671a68e1170607027589dfe1d9beba88a46a59e3ff3e2bb2d8df53b08b123528f850d0173cfffb0d529af4f7c667e31f089a87208ea SHA512 588b144c35c680f0f640068a18954f8d49441e52214399fbb2ebabc7116b54d31f1e74b6e21dc9223f78b24c0743153bd06aaafd525f945e7c0cac2e0ae47695
+EBUILD d-spy-1.8.0.ebuild 721 BLAKE2B 9e659351c8a59634e8052c27e299a80b1ea9974cd950c688520cc905ffca551bc61ea867473213c2c7cbbf085d54fb52087c4956d77e2b368c590dfd3fe77ef0 SHA512 e25c8244895efb177cbe6634e5ae2dd98b4ed494019ab01f89bbeeea2272bc857e99bd20ca824e7778b525a0f8622d4c409351d0e86cedcb293a1f60091647c8
+MISC metadata.xml 346 BLAKE2B ed5a5f063aa92eb582564f615a38bb8e3d71955f0c42cc91eb488d0cb81b615dd1bb05b8b833c9a225dddf2e6f5d3089983357a4dac0f81edac3303327dc3121 SHA512 fb5ae140eaf1130d78e8222253cc2c2ef059e7b3d7d765c2f1b8038f691e1119867be986b1585c981f07fe038ec010f427e1a758ec3d22c618cc7e289160274b
diff --git a/dev-debug/d-spy/d-spy-1.6.0.ebuild b/dev-debug/d-spy/d-spy-1.6.0.ebuild
new file mode 100644
index 000000000000..a3ef33127ea0
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.0:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/dev-debug/d-spy/d-spy-1.8.0.ebuild b/dev-debug/d-spy/d-spy-1.8.0.ebuild
new file mode 100644
index 000000000000..75eed80ac1d1
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.0:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/dev-debug/d-spy/metadata.xml b/dev-debug/d-spy/metadata.xml
new file mode 100644
index 000000000000..5da3a9ec9abb
--- /dev/null
+++ b/dev-debug/d-spy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/d-spy</remote-id>
+ </upstream>
+</pkgmetadata>