summaryrefslogtreecommitdiff
path: root/dev-db/tokyocabinet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-09 12:18:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-09 12:18:21 +0000
commit83c424cc446967ca87809e13c2ef264eebce79f8 (patch)
treebce1c3a7e1f36095b5a4956a97e7ec63d3414d41 /dev-db/tokyocabinet
parent92ed25ce2ff461f502de1dd96ab0accd683b69d2 (diff)
gentoo auto-resync : 09:01:2023 - 12:18:20
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/Manifest1
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48-r3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-db/tokyocabinet/Manifest b/dev-db/tokyocabinet/Manifest
index b9c5d1ebe1b5..0f8e3adc2c57 100644
--- a/dev-db/tokyocabinet/Manifest
+++ b/dev-db/tokyocabinet/Manifest
@@ -1,4 +1,5 @@
AUX fix_rpath.patch 1792 BLAKE2B 38d89cc47984b4d83e2df79b444cba657b814a0d9f80d0c3172c49984a7c22eac40d7c880872be632244fcc2efbf24c52b5613ecbdef624db47df97d6c27c1c1 SHA512 aca59f03c289ed2ffc1df1a387d7f141df56968866187324d14239258c6b270a8a56739bfea7c8398af90f52c5ec7a87eedba4194eb3b097cd0df05cc8553964
DIST tokyocabinet-1.4.48.tar.gz 1000485 BLAKE2B 4da2659a90dcee1cc99be286fe0e286ee75bd8179b75a944f229a3cc04169b8007220e36400d4934a7b5fde554bbc1783c4813fdf44b4a3530882ea0a8ef258e SHA512 b9995c838e713c13f781ab41062caefeb5c613f696dab08039f992f6860413d60a513114b83468cafdf7fc5b5e51ab880226972465d532f873f2a55f615e1440
EBUILD tokyocabinet-1.4.48-r2.ebuild 1651 BLAKE2B 2f877ce218520685a36db536a94628e4eeea161c04078126414159091363a19606e9466699f1e615d858779cb5a3dce6aaf003b037aae41b53b1fb2107074962 SHA512 01c2bdd227aee1fd9081d0d66995fb08fa65cd89c7502a647a0d7d5145514a40e14849f2336a5acc88dc551c8c367ac02381c0f3b7db3fbc3ecf129eb6def8a6
+EBUILD tokyocabinet-1.4.48-r3.ebuild 1644 BLAKE2B 188a618d9294701d1e339456ada9845702b4dd4798e32e8075f55bf8e5392d47b69860266e148d5f487d0c6d00b646c0623e0749ff07bdcdba76782757920313 SHA512 de9ec17c5f20f46174df5ab7a33eecb12420d6b6b0b320426dd9f28965f121d54933636a2e3f139e96585cae4b4effaa8bd483f9f0218ffc861d2b792ef7384a
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r3.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r3.ebuild
new file mode 100644
index 000000000000..4d76957c742e
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="https://fallabs.com/tokyocabinet/"
+SRC_URI="https://fallabs.com/tokyocabinet/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="bzip2 debug doc examples threads zlib"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/fix_rpath.patch" )
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/ldconfig/d" \
+ -e "/DATADIR/d" \
+ -i Makefile.in || die
+
+ # cflags fix - remove -O3 at end of line and -fomit-frame-pointer
+ sed -i -e 's/-O3"$/"/' configure.in || die
+ sed -i -e 's/-fomit-frame-pointer//' configure.in || die
+
+ # flag only works on x86 derivatives, remove everywhere else
+ if ! use x86 && ! use amd64; then
+ sed -i -e 's/ -minline-all-stringops//' configure.in || die
+ fi
+
+ sed -e 's/libtokyocabinet.a/libtokyocabinet.so/g' -i configure.in || die
+
+ AR="$(tc-getAR)"
+ eautoreconf
+}
+
+src_configure() {
+ # we use the "fastest" target without the -O3
+ myconf=(
+ --enable-off64
+ --enable-fastest
+ $(use_enable bzip2 bzip)
+ $(use_enable debug)
+ $(use_enable threads pthread)
+ $(use_enable zlib)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/.
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}