summaryrefslogtreecommitdiff
path: root/dev-db/tokumx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/tokumx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/tokumx/files')
-rw-r--r--dev-db/tokumx/files/1.5.0-Werror.diff45
-rw-r--r--dev-db/tokumx/files/1.5.0-boost-57.diff11
-rw-r--r--dev-db/tokumx/files/tokumx-2.0.2-boost-57.patch22
-rw-r--r--dev-db/tokumx/files/tokumx-2.0.2-no-werror.patch88
-rw-r--r--dev-db/tokumx/files/tokumx-disable-bundled-libs.patch11
5 files changed, 177 insertions, 0 deletions
diff --git a/dev-db/tokumx/files/1.5.0-Werror.diff b/dev-db/tokumx/files/1.5.0-Werror.diff
new file mode 100644
index 000000000000..a865fe074f37
--- /dev/null
+++ b/dev-db/tokumx/files/1.5.0-Werror.diff
@@ -0,0 +1,45 @@
+diff -uNr work.ORIG/mongo/CMakeLists.txt work/mongo/CMakeLists.txt
+--- work.ORIG/mongo/CMakeLists.txt 2014-08-01 11:51:20.832614062 +0100
++++ work/mongo/CMakeLists.txt 2014-08-01 11:51:36.898614862 +0100
+@@ -71,14 +71,13 @@
+ endforeach(flag)
+ endmacro(set_cxxflags_if_supported)
+
+-set(CMAKE_C_FLAGS "-fPIC -fno-strict-aliasing -ggdb -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -Werror -pipe")
++set(CMAKE_C_FLAGS "-fPIC -fno-strict-aliasing -ggdb -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -pipe")
+ set(CMAKE_CXX_FLAGS "-fPIC -fno-strict-aliasing -ggdb")
+ set_cxxflags_if_supported(
+ -Wall
+ -Wsign-compare
+ -Wno-unknown-pragmas
+ -Winvalid-pch
+- -Werror
+ -pipe
+ -Wnon-virtual-dtor
+ -Woverloaded-virtual
+diff -uNr work.ORIG/mongo/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake work/mongo/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake
+--- work.ORIG/mongo/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake 2014-08-01 11:51:20.696614056 +0100
++++ work/mongo/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake 2014-08-01 11:51:36.898614862 +0100
+@@ -174,8 +174,8 @@
+ endif ()
+
+ ## always want these
+-set(CMAKE_C_FLAGS "-Wall -Werror ${CMAKE_C_FLAGS}")
+-set(CMAKE_CXX_FLAGS "-Wall -Werror ${CMAKE_CXX_FLAGS}")
++set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
++set(CMAKE_CXX_FLAGS "-Wall ${CMAKE_CXX_FLAGS}")
+
+ ## need to set -stdlib=libc++ to get real c++11 support on darwin
+ if (APPLE)
+diff -uNr work.ORIG/mongo/src/third_party/ft-index/examples/Makefile work/mongo/src/third_party/ft-index/examples/Makefile
+--- work.ORIG/mongo/src/third_party/ft-index/examples/Makefile 2014-08-01 11:51:20.676614055 +0100
++++ work/mongo/src/third_party/ft-index/examples/Makefile 2014-08-01 11:51:36.898614862 +0100
+@@ -1,7 +1,7 @@
+ SRCS = $(wildcard *.c)
+ TARGETS = $(patsubst %.c,%,$(SRCS)) $(patsubst %.c,%-bdb,$(SRCS))
+ CPPFLAGS = -I../include -D_GNU_SOURCE
+-CFLAGS = -g -std=c99 -Wall -Wextra -Werror -Wno-missing-field-initializers
++CFLAGS = -g -std=c99 -Wall -Wextra -Wno-missing-field-initializers
+ ifeq ($(USE_STATIC_LIBS),1)
+ LIBTOKUDB = tokufractaltree_static
+ LIBTOKUPORTABILITY = tokuportability_static
diff --git a/dev-db/tokumx/files/1.5.0-boost-57.diff b/dev-db/tokumx/files/1.5.0-boost-57.diff
new file mode 100644
index 000000000000..e66aec168712
--- /dev/null
+++ b/dev-db/tokumx/files/1.5.0-boost-57.diff
@@ -0,0 +1,11 @@
+diff -uNr work.ORIG/mongo/src/mongo/shell/linenoise_utf8.h work/mongo/src/mongo/shell/linenoise_utf8.h
+--- work.ORIG/mongo/src/mongo/shell/linenoise_utf8.h 2017-03-30 15:20:51.880842717 +0100
++++ work/mongo/src/mongo/shell/linenoise_utf8.h 2017-03-30 15:21:26.002844416 +0100
+@@ -16,6 +16,7 @@
+ */
+
+ #include <boost/smart_ptr/scoped_array.hpp>
++#include <algorithm>
+ #include <string.h>
+
+ namespace linenoise_utf8 {
diff --git a/dev-db/tokumx/files/tokumx-2.0.2-boost-57.patch b/dev-db/tokumx/files/tokumx-2.0.2-boost-57.patch
new file mode 100644
index 000000000000..52b3b9f12064
--- /dev/null
+++ b/dev-db/tokumx/files/tokumx-2.0.2-boost-57.patch
@@ -0,0 +1,22 @@
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/mongo/shell/linenoise.cpp tokumx-enterprise-2.0.2/src/mongo/shell/linenoise.cpp
+--- tokumx-enterprise-2.0.2.ORIG/src/mongo/shell/linenoise.cpp 2016-11-21 11:52:54.883542356 +0000
++++ tokumx-enterprise-2.0.2/src/mongo/shell/linenoise.cpp 2016-11-21 11:53:11.995543208 +0000
+@@ -117,6 +117,7 @@
+ #include "mk_wcwidth.h"
+ #include <string>
+ #include <vector>
++#include <algorithm>
+ #include <boost/smart_ptr/scoped_array.hpp>
+
+ using std::string;
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/mongo/shell/linenoise_utf8.h tokumx-enterprise-2.0.2/src/mongo/shell/linenoise_utf8.h
+--- tokumx-enterprise-2.0.2.ORIG/src/mongo/shell/linenoise_utf8.h 2016-11-21 11:52:54.883542356 +0000
++++ tokumx-enterprise-2.0.2/src/mongo/shell/linenoise_utf8.h 2016-11-21 11:53:31.610544185 +0000
+@@ -15,6 +15,7 @@
+ * limitations under the License.
+ */
+
++#include <algorithm>
+ #include <boost/smart_ptr/scoped_array.hpp>
+ #include <string.h>
+
diff --git a/dev-db/tokumx/files/tokumx-2.0.2-no-werror.patch b/dev-db/tokumx/files/tokumx-2.0.2-no-werror.patch
new file mode 100644
index 000000000000..5a0c160e8866
--- /dev/null
+++ b/dev-db/tokumx/files/tokumx-2.0.2-no-werror.patch
@@ -0,0 +1,88 @@
+diff -uNr tokumx-enterprise-2.0.2.ORIG/CMakeLists.txt tokumx-enterprise-2.0.2/CMakeLists.txt
+--- tokumx-enterprise-2.0.2.ORIG/CMakeLists.txt 2016-11-21 11:15:27.517430430 +0000
++++ tokumx-enterprise-2.0.2/CMakeLists.txt 2016-11-21 11:16:27.874433436 +0000
+@@ -82,14 +82,13 @@
+ endforeach(flag)
+ endmacro(set_cxxflags_if_supported)
+
+-set(CMAKE_C_FLAGS "-fPIC -fno-strict-aliasing -ggdb -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -Werror -pipe")
++set(CMAKE_C_FLAGS "-fPIC -fno-strict-aliasing -ggdb -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -pipe")
+ set(CMAKE_CXX_FLAGS "-fPIC -fno-strict-aliasing -ggdb")
+ set_cxxflags_if_supported(
+ -Wall
+ -Wsign-compare
+ -Wno-unknown-pragmas
+ -Winvalid-pch
+- -Werror
+ -pipe
+ -Wnon-virtual-dtor
+ -Woverloaded-virtual
+diff -uNr tokumx-enterprise-2.0.2.ORIG/SConstruct tokumx-enterprise-2.0.2/SConstruct
+--- tokumx-enterprise-2.0.2.ORIG/SConstruct 2016-11-21 11:15:27.517430430 +0000
++++ tokumx-enterprise-2.0.2/SConstruct 2016-11-21 11:16:27.875433436 +0000
+@@ -710,7 +710,7 @@
+ "-Winvalid-pch"] )
+ # env.Append( " -Wconversion" ) TODO: this doesn't really work yet
+ if linux:
+- env.Append( CCFLAGS=["-Werror", "-pipe"] )
++ env.Append( CCFLAGS=["-pipe"] )
+ if not has_option('clang'):
+ env.Append( CCFLAGS=["-fno-builtin-memcmp"] ) # glibc's memcmp is faster than gcc's
+
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/third_party/backup/CMakeLists.txt tokumx-enterprise-2.0.2/src/third_party/backup/CMakeLists.txt
+--- tokumx-enterprise-2.0.2.ORIG/src/third_party/backup/CMakeLists.txt 2016-11-21 11:15:27.392430424 +0000
++++ tokumx-enterprise-2.0.2/src/third_party/backup/CMakeLists.txt 2016-11-21 11:17:22.576436161 +0000
+@@ -10,7 +10,7 @@
+ _FILE_OFFSET_BITS=64
+ _LARGEFILE64_SOURCE)
+
+-set(CMAKE_CXX_FLAGS "-Werror -W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
++set(CMAKE_CXX_FLAGS "-W -Wall -Wshadow ${CMAKE_CXX_FLAGS}")
+
+ set(USE_VALGRIND ON CACHE BOOL "whether to use valgrind headers")
+ if (USE_VALGRIND)
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/third_party/backup/remote/Makefile tokumx-enterprise-2.0.2/src/third_party/backup/remote/Makefile
+--- tokumx-enterprise-2.0.2.ORIG/src/third_party/backup/remote/Makefile 2016-11-21 11:15:27.393430424 +0000
++++ tokumx-enterprise-2.0.2/src/third_party/backup/remote/Makefile 2016-11-21 11:17:38.840436971 +0000
+@@ -1,4 +1,4 @@
+ backup.pb.o: backup.pb.h
+-CXXFLAGS = -W -Wall -Werror -O1
++CXXFLAGS = -W -Wall -O1
+ backup.pb.cc backup.bp.h: backup.proto
+ protoc -I=. --cpp_out=. backup.proto
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake tokumx-enterprise-2.0.2/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake
+--- tokumx-enterprise-2.0.2.ORIG/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake 2016-11-21 11:15:27.422430426 +0000
++++ tokumx-enterprise-2.0.2/src/third_party/ft-index/cmake_modules/TokuSetupCompiler.cmake 2016-11-21 11:16:54.312434753 +0000
+@@ -181,8 +181,8 @@
+ endif ()
+
+ ## always want these
+-set(CMAKE_C_FLAGS "-Wall -Werror ${CMAKE_C_FLAGS}")
+-set(CMAKE_CXX_FLAGS "-Wall -Werror ${CMAKE_CXX_FLAGS}")
++set(CMAKE_C_FLAGS "-Wall ${CMAKE_C_FLAGS}")
++set(CMAKE_CXX_FLAGS "-Wall ${CMAKE_CXX_FLAGS}")
+
+ ## need to set -stdlib=libc++ to get real c++11 support on darwin
+ if (APPLE)
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/third_party/v8/CMakeLists.txt tokumx-enterprise-2.0.2/src/third_party/v8/CMakeLists.txt
+--- tokumx-enterprise-2.0.2.ORIG/src/third_party/v8/CMakeLists.txt 2016-11-21 11:15:27.452430427 +0000
++++ tokumx-enterprise-2.0.2/src/third_party/v8/CMakeLists.txt 2016-11-21 11:16:27.876433437 +0000
+@@ -126,7 +126,6 @@
+
+ set(V8_CXX_FLAGS
+ -Wall
+- -Werror
+ -W
+ -Wno-unused-parameter
+ -Woverloaded-virtual
+diff -uNr tokumx-enterprise-2.0.2.ORIG/src/third_party/v8/SConscript tokumx-enterprise-2.0.2/src/third_party/v8/SConscript
+--- tokumx-enterprise-2.0.2.ORIG/src/third_party/v8/SConscript 2016-11-21 11:15:27.452430427 +0000
++++ tokumx-enterprise-2.0.2/src/third_party/v8/SConscript 2016-11-21 11:16:27.876433437 +0000
+@@ -47,7 +47,6 @@
+ 'gcc': {
+ 'all': {
+ 'CCFLAGS': ['-Wall',
+- '-Werror',
+ '-W',
+ '-Wno-unused-parameter',
+ '-Woverloaded-virtual',
diff --git a/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch b/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch
new file mode 100644
index 000000000000..66d8db3980fa
--- /dev/null
+++ b/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch
@@ -0,0 +1,11 @@
+diff -auwrN a/src/third_party/ft-index/CMakeLists.txt b/src/third_party/ft-index/CMakeLists.txt
+--- a/src/third_party/ft-index/CMakeLists.txt 2014-08-01 04:37:33.000000000 -0400
++++ b/src/third_party/ft-index/CMakeLists.txt 2014-08-01 10:38:28.134869689 -0400
+@@ -35,7 +35,6 @@
+ include(TokuFeatureDetection)
+ include(TokuSetupCompiler)
+ include(TokuSetupCTest)
+-include(TokuThirdParty)
+
+ set(TOKU_CMAKE_SCRIPT_DIR "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+ include(TokuMergeLibs)