summaryrefslogtreecommitdiff
path: root/dev-db/timescaledb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-db/timescaledb
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest4
-rw-r--r--dev-db/timescaledb/timescaledb-2.0.2.ebuild66
-rw-r--r--dev-db/timescaledb/timescaledb-2.1.0.ebuild66
3 files changed, 136 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index e90180efefad..d66a5b325b9b 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1,3 +1,7 @@
DIST timescaledb-2.0.1.tar.gz 2226320 BLAKE2B 0bd5011e30d6c0d5ac11b78ddf6650044f35d720317213bd0437a43e0421953708d3d69b6933a821d255b183bb72b1c5e34ff88223790266daf7af3cf21f2de2 SHA512 84e9c7da3f0fc6740eb0555bbd92f5511ceef4868fb1952650f9499f3054a4d2be59b3a042b17bf655155c9f9c1de82b6b4fb302bdad7ffbe893ed901adcefc0
+DIST timescaledb-2.0.2.tar.gz 2237429 BLAKE2B 58c5e68daf5a3c1fade48b2ce8f625496ee3c58be38c573c883e319eb0084064d243270ac839e4bdd1ce3c865fc6b916c7869232b995529d8aca77851a0c7a79 SHA512 26ce25e4d833810cdd99691f3b8a4d0c26655b2efeba7c25d5daaaf2d1aabd8f96a421a771da9c5b6cf29af66ddcab39f3881d40364e25c101ea691e4ec61116
+DIST timescaledb-2.1.0.tar.gz 2527250 BLAKE2B 6f257c4b1afc0869c8e309f9b3080dbcdda4b50debc1a5b3848b9d6e59744ff52902b475aca0bc8820aa2edebe9847d62e500a8cd19f7ab8050d9586d95d3a66 SHA512 53fddb9fe4c4ab51ebc020e90eea5b032b41259d3bd45e8a03a86451acd7f8864b5a6ecba1b82b7c78e230f62cfddf1da75ff27e6629ad5fe8178839ac411ce4
EBUILD timescaledb-2.0.1-r1.ebuild 1393 BLAKE2B d23f9c7b23f30ea412537613ebc3d22222ed9d729330edf7c236217f7f8f5063fcadf0ffdcee33af357fe4b77e5bc7fa5012ca4d209480292dd32430ecadbbe6 SHA512 786ad20862721c71d7a90a1fcb5ac3e46fd0d6238e03544f53cbbd6db04c84f84b90c5306552ff55ddf848e4e955836b0120ba189c32dd33ed3393c4dc896c4a
+EBUILD timescaledb-2.0.2.ebuild 1393 BLAKE2B d23f9c7b23f30ea412537613ebc3d22222ed9d729330edf7c236217f7f8f5063fcadf0ffdcee33af357fe4b77e5bc7fa5012ca4d209480292dd32430ecadbbe6 SHA512 786ad20862721c71d7a90a1fcb5ac3e46fd0d6238e03544f53cbbd6db04c84f84b90c5306552ff55ddf848e4e955836b0120ba189c32dd33ed3393c4dc896c4a
+EBUILD timescaledb-2.1.0.ebuild 1396 BLAKE2B 8a165aa634f877687a73267e951122009524cb858a8936660765e3c29ded3b7dab78e3fc851d02eec1c9d02383c62fcfdeace6baea2ae5553d956bea4ebbfeb4 SHA512 1a1811399f2af6daacf41e87464ae6da35033751832b3cb4c21acebedd08abfcee829d66e7eab9965e51a20257a773a74f7745c38d91181c382e3a5613256637
MISC metadata.xml 423 BLAKE2B a3a3492702b7cb6926726e2bc423baa3f9cedd29dd4c22d40d3e3b04e2513bd0a98cd003fcec34f6df4e0e01e653ecc550f38c8869f170bd8fbc08897ccd025c SHA512 cf01e5ba26d38251ef1fabdbf01f3190a077ba000b36682cc49c93b1f5149d1812e3e3a1dc659fa6e9acc39bcfc0dba2effd6588ef50e8d7834b4c68d7016801
diff --git a/dev-db/timescaledb/timescaledb-2.0.2.ebuild b/dev-db/timescaledb/timescaledb-2.0.2.ebuild
new file mode 100644
index 000000000000..9e97e6124c15
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}
diff --git a/dev-db/timescaledb/timescaledb-2.1.0.ebuild b/dev-db/timescaledb/timescaledb-2.1.0.ebuild
new file mode 100644
index 000000000000..54ea9700b357
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 13 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}