summaryrefslogtreecommitdiff
path: root/dev-db/timescaledb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-db/timescaledb
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest3
-rw-r--r--dev-db/timescaledb/metadata.xml13
-rw-r--r--dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild66
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
new file mode 100644
index 000000000000..e90180efefad
--- /dev/null
+++ b/dev-db/timescaledb/Manifest
@@ -0,0 +1,3 @@
+DIST timescaledb-2.0.1.tar.gz 2226320 BLAKE2B 0bd5011e30d6c0d5ac11b78ddf6650044f35d720317213bd0437a43e0421953708d3d69b6933a821d255b183bb72b1c5e34ff88223790266daf7af3cf21f2de2 SHA512 84e9c7da3f0fc6740eb0555bbd92f5511ceef4868fb1952650f9499f3054a4d2be59b3a042b17bf655155c9f9c1de82b6b4fb302bdad7ffbe893ed901adcefc0
+EBUILD timescaledb-2.0.1-r1.ebuild 1393 BLAKE2B d23f9c7b23f30ea412537613ebc3d22222ed9d729330edf7c236217f7f8f5063fcadf0ffdcee33af357fe4b77e5bc7fa5012ca4d209480292dd32430ecadbbe6 SHA512 786ad20862721c71d7a90a1fcb5ac3e46fd0d6238e03544f53cbbd6db04c84f84b90c5306552ff55ddf848e4e955836b0120ba189c32dd33ed3393c4dc896c4a
+MISC metadata.xml 423 BLAKE2B a3a3492702b7cb6926726e2bc423baa3f9cedd29dd4c22d40d3e3b04e2513bd0a98cd003fcec34f6df4e0e01e653ecc550f38c8869f170bd8fbc08897ccd025c SHA512 cf01e5ba26d38251ef1fabdbf01f3190a077ba000b36682cc49c93b1f5149d1812e3e3a1dc659fa6e9acc39bcfc0dba2effd6588ef50e8d7834b4c68d7016801
diff --git a/dev-db/timescaledb/metadata.xml b/dev-db/timescaledb/metadata.xml
new file mode 100644
index 000000000000..f450f64a07fa
--- /dev/null
+++ b/dev-db/timescaledb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>pgsql-bugs@gentoo.org</email>
+ <name>PostgreSQL and Related Package Development</name>
+ </maintainer>
+ <use>
+ <flag name="proprietary-extensions">
+ Enable proprietary features/extensions licensed under the TimeScale License
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild b/dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..9e97e6124c15
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.0.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}