summaryrefslogtreecommitdiff
path: root/dev-db/timescaledb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
commit744892aecb5cdf9ca0bbe504f7bbcdfb87b518fc (patch)
tree0b99b178b866e693a85d013eb47de3d1236e35b8 /dev-db/timescaledb
parent275074c50dca7b941cc7cd7966a2ace71c29ecae (diff)
gentoo auto-resync : 06:10:2022 - 19:22:30
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest2
-rw-r--r--dev-db/timescaledb/timescaledb-2.8.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index 4c42f1131882..4f5484975bb6 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1,5 +1,7 @@
DIST timescaledb-2.7.2.tar.gz 2990906 BLAKE2B 48ed3ad549e331d0f134ba3ecdb7ffe97e6c3aa7d4e8a46d9633def40c86c8be105b0ef15de74a1528f623031645dbf04a8500d13877e7619e95d58f21a5b82e SHA512 1f80ef166bce570d741da48cf7ae3739d6be37802674d9be100017e50936f99ce7c6927c8ddbe290abfede307bfe8442701f5edf85f64669801fd859bc105804
DIST timescaledb-2.8.0.tar.gz 6768327 BLAKE2B cc6895f4389c1a0b04bf492432325212b0ee8bd4b2a6c3c8ba1abbd36bd5ae9ec4a95e520100d87ba0f787fb25c0b98dd42667330b3ba9d72d06e36dc66c0426 SHA512 0d9c947b230b2aecfa8d6bc8c0a995fe2847e8851fff58d5fcfab532cf54581f72acd2c9eaa8e55bd5e425db5c31baa4bef83ccd41413a26ce0a9c940d2ab6db
+DIST timescaledb-2.8.1.tar.gz 6789998 BLAKE2B 63684a5e18bf6104700bb0d78f5fb16bad35627160e1b96f1688b6b1065da9fd03377d5e56e4832da2e04879bbf416d31587bcc27e9b5a01b635a963515f60ef SHA512 69dfea5874d5c1ca8fef1382b8fc49d709a09908009fe38fe4ae44bebdae701615e3cbeb2f3ecd2044babd1a7c6ff255f96fa31f94f84293cfba942542775c54
EBUILD timescaledb-2.7.2.ebuild 1434 BLAKE2B d1c472204d3055d48060bd78c12aea4a98ea23b3b242d41d2fefa85fe0c9d5035ed4277d6ee42d1ec12540475e4eb586e08e87e88c871fa4d1fabd064e45a234 SHA512 cf76e892e19dd4d1f2ccdb9f2bbf73cfd52fbb4ab4ee8ba1e9dec7a35beb15196e7e5b3d783662e1669920ea0e77c5f00a1edf2d418de697d72dbb8b5c7065dd
EBUILD timescaledb-2.8.0.ebuild 1434 BLAKE2B d1c472204d3055d48060bd78c12aea4a98ea23b3b242d41d2fefa85fe0c9d5035ed4277d6ee42d1ec12540475e4eb586e08e87e88c871fa4d1fabd064e45a234 SHA512 cf76e892e19dd4d1f2ccdb9f2bbf73cfd52fbb4ab4ee8ba1e9dec7a35beb15196e7e5b3d783662e1669920ea0e77c5f00a1edf2d418de697d72dbb8b5c7065dd
+EBUILD timescaledb-2.8.1.ebuild 1434 BLAKE2B d1c472204d3055d48060bd78c12aea4a98ea23b3b242d41d2fefa85fe0c9d5035ed4277d6ee42d1ec12540475e4eb586e08e87e88c871fa4d1fabd064e45a234 SHA512 cf76e892e19dd4d1f2ccdb9f2bbf73cfd52fbb4ab4ee8ba1e9dec7a35beb15196e7e5b3d783662e1669920ea0e77c5f00a1edf2d418de697d72dbb8b5c7065dd
MISC metadata.xml 424 BLAKE2B 8cbf1315da7aa52b81fb2b141d7d34100cd838667ec366ba000fb914251cddd35632d9f9b8f6200bf4b679683db9c487522d18bedb4b371f92651c26a3e6121b SHA512 8e8b90dec46092f8d7dd36e67fa000e3f4c108f80903ebd3dad4965bbb4797bf952208afa7e90646946207382547fdd59d4d282379a898a3121b91f86e090c20
diff --git a/dev-db/timescaledb/timescaledb-2.8.1.ebuild b/dev-db/timescaledb/timescaledb-2.8.1.ebuild
new file mode 100644
index 000000000000..b6b5d265256d
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 12 13 14 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}