summaryrefslogtreecommitdiff
path: root/dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
commit97bacba3ead078e5db8b87ab651a3ffa7d82f60f (patch)
treea769244c0cdbaa4ae87951809f61da3a3f9df7a4 /dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild
parentb92911550490e2da121ec4b02d3cf60a2d31a17d (diff)
gentoo auto-resync : 17:04:2024 - 12:04:27
Diffstat (limited to 'dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild')
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild
new file mode 100644
index 000000000000..f36aabb52938
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="https://sourceforge.net/projects/sqliteman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ >=x11-libs/qscintilla-2.10.3:=[qt5(+)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-lpthread.patch"
+ "${FILESDIR}/${P}-qt5.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-desktop.patch"
+)
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf ${PN}/qscintilla2 || die
+
+ append-flags -fPIC
+ cmake_src_prepare
+}