summaryrefslogtreecommitdiff
path: root/dev-db/spatialite-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/spatialite-tools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/spatialite-tools')
-rw-r--r--dev-db/spatialite-tools/Manifest3
-rw-r--r--dev-db/spatialite-tools/metadata.xml8
-rw-r--r--dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/spatialite-tools/Manifest b/dev-db/spatialite-tools/Manifest
new file mode 100644
index 000000000000..628205bbddb8
--- /dev/null
+++ b/dev-db/spatialite-tools/Manifest
@@ -0,0 +1,3 @@
+DIST spatialite-tools-4.3.0.tar.gz 540811 BLAKE2B 3de4301380a0b64cdd388cb0dc1917b90a02a721b1e34d3781b5b4e14a810809c922a3760a269c3980790801b66a100f9bacf1249f2874374295b5bb9431b133 SHA512 e1de27c1c65ff2ff0b08583113517bea74edf33fff59ad6e9c77492ea3ae87d9c0f17d7670ee6602b32eea73ad3678bb5410ef2c6fac6e213bf2e341a907db88
+EBUILD spatialite-tools-4.3.0-r1.ebuild 666 BLAKE2B 2c650ad394cf4a945713a89c4cdb80e41e55279e98003cb31054cb2c55d16671322d04538b7018c10ae3bb764e9c735adf1e900a4bf570fb5b41646a98fa6d85 SHA512 20ceb663ce052d6955229d7667e23d0674f5edffa62b73bdba8b24b051f97f0e989826d9d0c9320f7f7edd564b5c6c416e5cb5beb3cdbc58ca71561ba90c131c
+MISC metadata.xml 269 BLAKE2B d4815f943b682786bd83cbc5840e99f36fc2f1bf175394ef9389228bfa8bd22b1bfbbf763eb9c396338b72b7927b431e73598bb67eaadf1d437c4afa5877c189 SHA512 9877d09d42c801d752617b41c7fb790db8e10c033c02ee9fe9a04fa1c6a8ea06d3baeb4f81d041b57e883d5d9dadb429289faae90d0293c62334ba35549e0276
diff --git a/dev-db/spatialite-tools/metadata.xml b/dev-db/spatialite-tools/metadata.xml
new file mode 100644
index 000000000000..2761b1b9e5c0
--- /dev/null
+++ b/dev-db/spatialite-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..a4a242e63a90
--- /dev/null
+++ b/dev-db/spatialite-tools/spatialite-tools-4.3.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of CLI tools supporting SpatiaLite"
+HOMEPAGE="https://www.gaia-gis.it/spatialite"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+RDEPEND="
+ dev-db/sqlite:3[extensions(+)]
+ >=dev-db/spatialite-3.0.1[geos,xls]
+ dev-libs/expat
+ dev-libs/libxml2
+ sci-geosciences/readosm
+ sci-libs/geos
+ sci-libs/proj
+ readline? (
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable readline)
+}