summaryrefslogtreecommitdiff
path: root/dev-db/rqlite/rqlite-7.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-09 00:17:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-09 00:17:07 +0000
commit4fc232f0223106ced390fbe949c095cb39143f23 (patch)
treecbe7ad1f19d2a427ec23a82842e743a1aa49cd49 /dev-db/rqlite/rqlite-7.13.1.ebuild
parent2237cda0c6b012952e02ec1314e1f48eddf4dab7 (diff)
gentoo auto-resync : 09:01:2023 - 00:17:07
Diffstat (limited to 'dev-db/rqlite/rqlite-7.13.1.ebuild')
-rw-r--r--dev-db/rqlite/rqlite-7.13.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/rqlite/rqlite-7.13.1.ebuild b/dev-db/rqlite/rqlite-7.13.1.ebuild
new file mode 100644
index 000000000000..44169ca17d37
--- /dev/null
+++ b/dev-db/rqlite/rqlite-7.13.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+EGIT_COMMIT=62e43d8de1784178b876ec33867b80aac0554282
+
+DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
+HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
+SRC_URI="https://github.com/zmedico/rqlite/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
+
+LICENSE="MIT Apache-2.0 BSD CC0-1.0 MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-vendor
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ go install \
+ -ldflags="-X main.version=v${PV}
+ -X main.branch=master
+ -X main.commit=${EGIT_COMMIT}
+ -X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
+ ./cmd/... || die
+}
+
+src_test() {
+ GOBIN="${S}/bin" \
+ go test ./... || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r *.md DOC
+}