summaryrefslogtreecommitdiff
path: root/dev-db/rqlite/rqlite-7.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 05:14:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 05:14:30 +0000
commit2502c34a847594fd68051817c7c19d8f0b81c595 (patch)
treeb9a8052ae93b25d20677ec47d771d59b729ca0e7 /dev-db/rqlite/rqlite-7.13.0.ebuild
parent145b1805c3986974378af5c60767504ecc9ed280 (diff)
gentoo auto-resync : 11:12:2023 - 05:14:30
Diffstat (limited to 'dev-db/rqlite/rqlite-7.13.0.ebuild')
-rw-r--r--dev-db/rqlite/rqlite-7.13.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-db/rqlite/rqlite-7.13.0.ebuild b/dev-db/rqlite/rqlite-7.13.0.ebuild
deleted file mode 100644
index e8ba1b76a19a..000000000000
--- a/dev-db/rqlite/rqlite-7.13.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module
-EGIT_COMMIT=f4a1583d3a63e55ddc7d310c64d8a6cd0a0f2b1d
-
-DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
-HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
-SRC_URI="https://github.com/zmedico/rqlite/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
-
-LICENSE="MIT Apache-2.0 BSD CC0-1.0 MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${P}-vendor
-
-src_compile() {
- GOBIN="${S}/bin" \
- go install \
- -ldflags="-X main.version=v${PV}
- -X main.branch=master
- -X main.commit=${EGIT_COMMIT}
- -X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
- ./cmd/... || die
-}
-
-src_test() {
- GOBIN="${S}/bin" \
- go test ./... || die
-}
-
-src_install() {
- dobin bin/*
- dodoc -r *.md DOC
-}